summaryrefslogtreecommitdiffstats
path: root/package/classpath/classpath.mk
diff options
context:
space:
mode:
Diffstat (limited to 'package/classpath/classpath.mk')
-rw-r--r--package/classpath/classpath.mk6
1 files changed, 4 insertions, 2 deletions
diff --git a/package/classpath/classpath.mk b/package/classpath/classpath.mk
index 62167aace..c3051785e 100644
--- a/package/classpath/classpath.mk
+++ b/package/classpath/classpath.mk
@@ -17,8 +17,10 @@ CLASSPATH_CONF_OPT = \
# classpath assumes qt runs on top of X11, but we
# don't support qt4 on X11
CLASSPATH_CONF_OPT += --disable-qt-peer
-
CLASSPATH_DEPENDENCIES = host-pkgconf
+CLASSPATH_AUTORECONF = YES
+CLASSPATH_LICENSE = GPLv2+ with exception
+CLASSPATH_LICENSE_FILES = COPYING
ifeq ($(BR2_PACKAGE_ALSA_LIB),y)
CLASSPATH_CONF_OPT += --enable-alsa
@@ -28,7 +30,7 @@ CLASSPATH_CONF_OPT += --disable-alsa
endif
ifeq ($(BR2_PACKAGE_GMP),y)
-CLASSPATH_CONF_OPT += --enable-gmp
+CLASSPATH_CONF_OPT += --enable-gmp --with-gmp="$(STAGING_DIR)/usr"
CLASSPATH_DEPENDENCIES += gmp
else
CLASSPATH_CONF_OPT += --disable-gmp