summaryrefslogtreecommitdiffstats
path: root/package/classpath/classpath.mk
diff options
context:
space:
mode:
authorGustavo Zacarias <gustavo@zacarias.com.ar>2013-07-04 12:59:31 -0300
committerPeter Korsgaard <jacmet@sunsite.dk>2013-07-08 00:05:25 +0200
commit44b16fb3972757e8936f753bca8c8bf621b5ef2b (patch)
tree7ce6953f6b6a7165d49c6cc7ce405988599c8740 /package/classpath/classpath.mk
parent9cb3d08194942aad04ab9a07d85762a726ad1956 (diff)
downloadbuildroot-novena-44b16fb3972757e8936f753bca8c8bf621b5ef2b.tar.gz
buildroot-novena-44b16fb3972757e8936f753bca8c8bf621b5ef2b.zip
classpath: fix build errors with gmp support
gmp support has a hardcoded /usr/include include PATH which causes breakage when there is a distribution gmp with development headers installed. Fixes: http://autobuild.buildroot.net/results/849/8497648c0b21390782eecc5b4aa91281bcf58ad6/ Signed-off-by: Gustavo Zacarias <gustavo@zacarias.com.ar> Signed-off-by: Peter Korsgaard <jacmet@sunsite.dk>
Diffstat (limited to 'package/classpath/classpath.mk')
-rw-r--r--package/classpath/classpath.mk6
1 files changed, 4 insertions, 2 deletions
diff --git a/package/classpath/classpath.mk b/package/classpath/classpath.mk
index 62167aace..c3051785e 100644
--- a/package/classpath/classpath.mk
+++ b/package/classpath/classpath.mk
@@ -17,8 +17,10 @@ CLASSPATH_CONF_OPT = \
# classpath assumes qt runs on top of X11, but we
# don't support qt4 on X11
CLASSPATH_CONF_OPT += --disable-qt-peer
-
CLASSPATH_DEPENDENCIES = host-pkgconf
+CLASSPATH_AUTORECONF = YES
+CLASSPATH_LICENSE = GPLv2+ with exception
+CLASSPATH_LICENSE_FILES = COPYING
ifeq ($(BR2_PACKAGE_ALSA_LIB),y)
CLASSPATH_CONF_OPT += --enable-alsa
@@ -28,7 +30,7 @@ CLASSPATH_CONF_OPT += --disable-alsa
endif
ifeq ($(BR2_PACKAGE_GMP),y)
-CLASSPATH_CONF_OPT += --enable-gmp
+CLASSPATH_CONF_OPT += --enable-gmp --with-gmp="$(STAGING_DIR)/usr"
CLASSPATH_DEPENDENCIES += gmp
else
CLASSPATH_CONF_OPT += --disable-gmp