summaryrefslogtreecommitdiffstats
path: root/package/busybox
diff options
context:
space:
mode:
Diffstat (limited to 'package/busybox')
-rw-r--r--package/busybox/busybox.mk6
1 files changed, 4 insertions, 2 deletions
diff --git a/package/busybox/busybox.mk b/package/busybox/busybox.mk
index 4931b0744..509c3bb9f 100644
--- a/package/busybox/busybox.mk
+++ b/package/busybox/busybox.mk
@@ -123,8 +123,10 @@ endef
endif
define BUSYBOX_INSTALL_LOGGING_SCRIPT
- $(INSTALL) -m 0755 -D package/busybox/S01logging \
- $(TARGET_DIR)/etc/init.d/S01logging
+ if grep -q CONFIG_SYSLOGD=y $(@D)/.config; then \
+ $(INSTALL) -m 0755 -D package/busybox/S01logging \
+ $(TARGET_DIR)/etc/init.d/S01logging; \
+ else rm -f $(TARGET_DIR)/etc/init.d/S01logging; fi
endef
# We do this here to avoid busting a modified .config in configure