summaryrefslogtreecommitdiffstats
path: root/package/busybox
diff options
context:
space:
mode:
authorPeter Korsgaard <jacmet@sunsite.dk>2011-07-04 21:03:37 +0200
committerPeter Korsgaard <jacmet@sunsite.dk>2011-07-04 21:03:37 +0200
commitabf7af17e95855e9fe2535729f7d83fce603463f (patch)
treea0c994bf8f5dc408aac8bc04aa2ebf16d0691974 /package/busybox
parentad501b6634dc9d974da7e86299041fe441d58088 (diff)
downloadbuildroot-novena-abf7af17e95855e9fe2535729f7d83fce603463f.tar.gz
buildroot-novena-abf7af17e95855e9fe2535729f7d83fce603463f.zip
busybox: only install S01logging if syslogd applet is enabled
Signed-off-by: Peter Korsgaard <jacmet@sunsite.dk>
Diffstat (limited to 'package/busybox')
-rw-r--r--package/busybox/busybox.mk6
1 files changed, 4 insertions, 2 deletions
diff --git a/package/busybox/busybox.mk b/package/busybox/busybox.mk
index 4931b0744..509c3bb9f 100644
--- a/package/busybox/busybox.mk
+++ b/package/busybox/busybox.mk
@@ -123,8 +123,10 @@ endef
endif
define BUSYBOX_INSTALL_LOGGING_SCRIPT
- $(INSTALL) -m 0755 -D package/busybox/S01logging \
- $(TARGET_DIR)/etc/init.d/S01logging
+ if grep -q CONFIG_SYSLOGD=y $(@D)/.config; then \
+ $(INSTALL) -m 0755 -D package/busybox/S01logging \
+ $(TARGET_DIR)/etc/init.d/S01logging; \
+ else rm -f $(TARGET_DIR)/etc/init.d/S01logging; fi
endef
# We do this here to avoid busting a modified .config in configure