summaryrefslogtreecommitdiffstats
path: root/package/boost/boost.mk
diff options
context:
space:
mode:
Diffstat (limited to 'package/boost/boost.mk')
-rw-r--r--package/boost/boost.mk4
1 files changed, 2 insertions, 2 deletions
diff --git a/package/boost/boost.mk b/package/boost/boost.mk
index 005c7ca75..62226ba22 100644
--- a/package/boost/boost.mk
+++ b/package/boost/boost.mk
@@ -46,10 +46,10 @@ BOOST_FLAGS += --without-icu
endif
BOOST_OPT += toolset=gcc \
+ threading=multi \
variant=$(if $(BR2_ENABLE_DEBUG),debug,release) \
link=$(if $(BR2_PREFER_STATIC_LIB),static,shared) \
- runtime-link=$(if $(BR2_PREFER_STATIC_LIB),static,shared) \
- threading=$(if $(BR2_PACKAGE_BOOST_MULTITHREADED),multi,single)
+ runtime-link=$(if $(BR2_PREFER_STATIC_LIB),static,shared)
ifeq ($(BR2_PACKAGE_BOOST_LOCALE),y)
ifeq ($(BR2_TOOLCHAIN_BUILDROOT)$(BR2_TOOLCHAIN_EXTERNAL_UCLIBC)$(BR2_TOOLCHAIN_CTNG_uClibc),y)