summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--package/boost/Config.in15
-rw-r--r--package/boost/boost.mk4
2 files changed, 8 insertions, 11 deletions
diff --git a/package/boost/Config.in b/package/boost/Config.in
index fb5360ecf..19dcc6044 100644
--- a/package/boost/Config.in
+++ b/package/boost/Config.in
@@ -1,10 +1,14 @@
-comment "boost requires a toolchain with C++ and large file support enabled"
- depends on !BR2_INSTALL_LIBSTDCPP || !BR2_LARGEFILE
+comment "boost requires a toolchain with C++, large file and thread support enabled"
+ depends on !BR2_INSTALL_LIBSTDCPP || !BR2_LARGEFILE || !BR2_TOOLCHAIN_HAS_THREADS
config BR2_PACKAGE_BOOST
bool "boost"
depends on BR2_INSTALL_LIBSTDCPP
depends on BR2_LARGEFILE
+ # Boost could theorically be built with threading=single, but
+ # that unfortunately doesn't work. Until someone fixes that,
+ # let's depend on threads.
+ depends on BR2_TOOLCHAIN_HAS_THREADS
select BR2_PACKAGE_BZIP2
select BR2_PACKAGE_ZLIB
help
@@ -14,12 +18,6 @@ config BR2_PACKAGE_BOOST
if BR2_PACKAGE_BOOST
-config BR2_PACKAGE_BOOST_MULTITHREADED
- depends on BR2_TOOLCHAIN_HAS_THREADS
- bool "boost-multithreaded"
- help
- Build the boost libraries as multithreaded
-
config BR2_PACKAGE_BOOST_CHRONO
bool "boost-chrono"
@@ -76,7 +74,6 @@ config BR2_PACKAGE_BOOST_TEST
bool "boost-test"
config BR2_PACKAGE_BOOST_THREAD
- depends on BR2_TOOLCHAIN_HAS_THREADS
bool "boost-thread"
config BR2_PACKAGE_BOOST_TIMER
diff --git a/package/boost/boost.mk b/package/boost/boost.mk
index 005c7ca75..62226ba22 100644
--- a/package/boost/boost.mk
+++ b/package/boost/boost.mk
@@ -46,10 +46,10 @@ BOOST_FLAGS += --without-icu
endif
BOOST_OPT += toolset=gcc \
+ threading=multi \
variant=$(if $(BR2_ENABLE_DEBUG),debug,release) \
link=$(if $(BR2_PREFER_STATIC_LIB),static,shared) \
- runtime-link=$(if $(BR2_PREFER_STATIC_LIB),static,shared) \
- threading=$(if $(BR2_PACKAGE_BOOST_MULTITHREADED),multi,single)
+ runtime-link=$(if $(BR2_PREFER_STATIC_LIB),static,shared)
ifeq ($(BR2_PACKAGE_BOOST_LOCALE),y)
ifeq ($(BR2_TOOLCHAIN_BUILDROOT)$(BR2_TOOLCHAIN_EXTERNAL_UCLIBC)$(BR2_TOOLCHAIN_CTNG_uClibc),y)