summaryrefslogtreecommitdiffstats
path: root/boot
diff options
context:
space:
mode:
Diffstat (limited to 'boot')
-rw-r--r--boot/uboot/Config.in3
-rw-r--r--boot/uboot/uboot.mk4
2 files changed, 6 insertions, 1 deletions
diff --git a/boot/uboot/Config.in b/boot/uboot/Config.in
index a1874a158..aadf75707 100644
--- a/boot/uboot/Config.in
+++ b/boot/uboot/Config.in
@@ -98,6 +98,9 @@ config BR2_TARGET_UBOOT_FORMAT_LDR
depends on BR2_bfin
bool "u-boot.ldr"
+config BR2_TARGET_UBOOT_FORMAT_ELF
+ bool "u-boot.elf"
+
endchoice
config BR2_TARGET_UBOOT_OMAP_IFT
diff --git a/boot/uboot/uboot.mk b/boot/uboot/uboot.mk
index 3e188ee8a..b357e0f06 100644
--- a/boot/uboot/uboot.mk
+++ b/boot/uboot/uboot.mk
@@ -26,7 +26,9 @@ UBOOT_SITE = ftp://ftp.denx.de/pub/u-boot
UBOOT_SOURCE = u-boot-$(UBOOT_VERSION).tar.bz2
endif
-ifeq ($(BR2_TARGET_UBOOT_FORMAT_KWB),y)
+ifeq ($(BR2_TARGET_UBOOT_FORMAT_ELF),y)
+UBOOT_BIN = u-boot
+else ifeq ($(BR2_TARGET_UBOOT_FORMAT_KWB),y)
UBOOT_BIN = u-boot.kwb
UBOOT_MAKE_TARGET = $(UBOOT_BIN)
else ifeq ($(BR2_TARGET_UBOOT_FORMAT_AIS),y)