summaryrefslogtreecommitdiffstats
path: root/boot
diff options
context:
space:
mode:
authorSpenser Gilliland <Spenser309@gmail.com>2013-05-15 18:12:02 -0500
committerPeter Korsgaard <jacmet@sunsite.dk>2013-06-15 23:24:09 +0200
commit4d27205ab1c140f9d81fa200f36d118a3dbdad33 (patch)
tree80b67713de0c55ba1deb2a2656319cdd7fbd4b1d /boot
parent7c6a2995ddb045e5c0617997a9f1fe1f4b382571 (diff)
downloadbuildroot-novena-4d27205ab1c140f9d81fa200f36d118a3dbdad33.tar.gz
buildroot-novena-4d27205ab1c140f9d81fa200f36d118a3dbdad33.zip
uboot: Add ELF target
adds ELF image option to uboot Signed-off-by: Spenser Gilliland <spenser@gillilanding.com> Signed-off-by: Peter Korsgaard <jacmet@sunsite.dk>
Diffstat (limited to 'boot')
-rw-r--r--boot/uboot/Config.in3
-rw-r--r--boot/uboot/uboot.mk4
2 files changed, 6 insertions, 1 deletions
diff --git a/boot/uboot/Config.in b/boot/uboot/Config.in
index a1874a158..aadf75707 100644
--- a/boot/uboot/Config.in
+++ b/boot/uboot/Config.in
@@ -98,6 +98,9 @@ config BR2_TARGET_UBOOT_FORMAT_LDR
depends on BR2_bfin
bool "u-boot.ldr"
+config BR2_TARGET_UBOOT_FORMAT_ELF
+ bool "u-boot.elf"
+
endchoice
config BR2_TARGET_UBOOT_OMAP_IFT
diff --git a/boot/uboot/uboot.mk b/boot/uboot/uboot.mk
index 3e188ee8a..b357e0f06 100644
--- a/boot/uboot/uboot.mk
+++ b/boot/uboot/uboot.mk
@@ -26,7 +26,9 @@ UBOOT_SITE = ftp://ftp.denx.de/pub/u-boot
UBOOT_SOURCE = u-boot-$(UBOOT_VERSION).tar.bz2
endif
-ifeq ($(BR2_TARGET_UBOOT_FORMAT_KWB),y)
+ifeq ($(BR2_TARGET_UBOOT_FORMAT_ELF),y)
+UBOOT_BIN = u-boot
+else ifeq ($(BR2_TARGET_UBOOT_FORMAT_KWB),y)
UBOOT_BIN = u-boot.kwb
UBOOT_MAKE_TARGET = $(UBOOT_BIN)
else ifeq ($(BR2_TARGET_UBOOT_FORMAT_AIS),y)