summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--CHANGES10
-rw-r--r--package/libnl/libnl.mk4
2 files changed, 9 insertions, 5 deletions
diff --git a/CHANGES b/CHANGES
index 20290ddae..b1f41352e 100644
--- a/CHANGES
+++ b/CHANGES
@@ -6,11 +6,11 @@
Updated/fixed packages: autoconf, busybox, directfb, dnsmasq,
e2fsprogs, festival, gstreamer, gst-plugins-bad, gst-plugins-base,
gst-plugins-good, imagemagick, iptables, kernel-headers, kismet,
- libevent, libglib2, liblockfile, libmad, libupnp, libuuid, ltrace,
- lua, mdadm, ncftp, ncurses, netkittelnet, ntfs-3g, openssl, php,
- python, quagga, radvd, rsync, samba, shared-mime-info, speech-tools,
- squashfs, syslinux, u-boot, util-linux, valgrind, vsftpd, wipe,
- wpa-supplicant, xdata_xcursor-themes, zlib
+ libevent, libglib2, liblockfile, libmad, libnl, libupnp, libuuid,
+ ltrace, lua, mdadm, ncftp, ncurses, netkittelnet, ntfs-3g, openssl,
+ php, python, quagga, radvd, rsync, samba, shared-mime-info,
+ speech-tools, squashfs, syslinux, u-boot, util-linux, valgrind,
+ vsftpd, wipe, wpa-supplicant, xdata_xcursor-themes, zlib
Removed package: mdnsresponder, mpatrol
diff --git a/package/libnl/libnl.mk b/package/libnl/libnl.mk
index 1a667468d..04bac2dca 100644
--- a/package/libnl/libnl.mk
+++ b/package/libnl/libnl.mk
@@ -13,10 +13,14 @@ LIBNL_INSTALL_TARGET_OPT = DESTDIR=$(TARGET_DIR) install
$(eval $(call AUTOTARGETS,package,libnl))
$(LIBNL_HOOK_POST_INSTALL): $(LIBNL_TARGET_INSTALL_TARGET)
+ifneq ($(BR2_ENABLE_DEBUG),y)
$(STRIPCMD) $(STRIP_STRIP_UNNEEDED) $(TARGET_DIR)/usr/lib/libnl.so*
+ $(STRIPCMD) $(STRIP_STRIP_UNNEEDED) $(TARGET_DIR)/usr/lib/libnl-*.so*
+endif
touch $@
$(LIBNL_TARGET_UNINSTALL):
$(call MESSAGE,"Uninstalling")
rm -f $(TARGET_DIR)/usr/lib/libnl.so*
+ rm -f $(TARGET_DIR)/usr/lib/libnl-*.so*
rm -f $(LIBNL_TARGET_INSTALL_TARGET) $(LIBNL_HOOK_POST_INSTALL)