summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorSven Neumann <s.neumann@raumfeld.com>2009-10-19 23:45:58 +0200
committerPeter Korsgaard <jacmet@sunsite.dk>2009-10-21 10:19:23 +0200
commit61901bd74a622450139358ea0c0f37d4568ad570 (patch)
treec87d070084dbeebe63686a16495bd953aa5a7648
parent0ad5869528742f90791b6a13b94f1fa49c41e809 (diff)
downloadbuildroot-novena-61901bd74a622450139358ea0c0f37d4568ad570.tar.gz
buildroot-novena-61901bd74a622450139358ea0c0f37d4568ad570.zip
libnl: handle all installed libraries
libnl does not only install libnl.so, but also libnl-nf.so, libnl-genl.so and libnl-route.so. Change the post-install and uninstall hooks to handle these libraries as well. Signed-off-by: Sven Neumann <s.neumann@raumfeld.com> Signed-off-by: Peter Korsgaard <jacmet@sunsite.dk>
-rw-r--r--CHANGES10
-rw-r--r--package/libnl/libnl.mk4
2 files changed, 9 insertions, 5 deletions
diff --git a/CHANGES b/CHANGES
index 20290ddae..b1f41352e 100644
--- a/CHANGES
+++ b/CHANGES
@@ -6,11 +6,11 @@
Updated/fixed packages: autoconf, busybox, directfb, dnsmasq,
e2fsprogs, festival, gstreamer, gst-plugins-bad, gst-plugins-base,
gst-plugins-good, imagemagick, iptables, kernel-headers, kismet,
- libevent, libglib2, liblockfile, libmad, libupnp, libuuid, ltrace,
- lua, mdadm, ncftp, ncurses, netkittelnet, ntfs-3g, openssl, php,
- python, quagga, radvd, rsync, samba, shared-mime-info, speech-tools,
- squashfs, syslinux, u-boot, util-linux, valgrind, vsftpd, wipe,
- wpa-supplicant, xdata_xcursor-themes, zlib
+ libevent, libglib2, liblockfile, libmad, libnl, libupnp, libuuid,
+ ltrace, lua, mdadm, ncftp, ncurses, netkittelnet, ntfs-3g, openssl,
+ php, python, quagga, radvd, rsync, samba, shared-mime-info,
+ speech-tools, squashfs, syslinux, u-boot, util-linux, valgrind,
+ vsftpd, wipe, wpa-supplicant, xdata_xcursor-themes, zlib
Removed package: mdnsresponder, mpatrol
diff --git a/package/libnl/libnl.mk b/package/libnl/libnl.mk
index 1a667468d..04bac2dca 100644
--- a/package/libnl/libnl.mk
+++ b/package/libnl/libnl.mk
@@ -13,10 +13,14 @@ LIBNL_INSTALL_TARGET_OPT = DESTDIR=$(TARGET_DIR) install
$(eval $(call AUTOTARGETS,package,libnl))
$(LIBNL_HOOK_POST_INSTALL): $(LIBNL_TARGET_INSTALL_TARGET)
+ifneq ($(BR2_ENABLE_DEBUG),y)
$(STRIPCMD) $(STRIP_STRIP_UNNEEDED) $(TARGET_DIR)/usr/lib/libnl.so*
+ $(STRIPCMD) $(STRIP_STRIP_UNNEEDED) $(TARGET_DIR)/usr/lib/libnl-*.so*
+endif
touch $@
$(LIBNL_TARGET_UNINSTALL):
$(call MESSAGE,"Uninstalling")
rm -f $(TARGET_DIR)/usr/lib/libnl.so*
+ rm -f $(TARGET_DIR)/usr/lib/libnl-*.so*
rm -f $(LIBNL_TARGET_INSTALL_TARGET) $(LIBNL_HOOK_POST_INSTALL)