summaryrefslogtreecommitdiffstats
path: root/toolchain/toolchain-crosstool-ng
diff options
context:
space:
mode:
authorPeter Korsgaard <jacmet@sunsite.dk>2011-07-27 11:51:47 +0200
committerPeter Korsgaard <jacmet@sunsite.dk>2011-07-27 11:56:53 +0200
commit4ee9d569f9ae5da199b6e64a45d83dc6aa9c78ce (patch)
tree4104eb52b3319136dfa220d693ccf17919b75b3f /toolchain/toolchain-crosstool-ng
parent213bbe9a2281f47eb1f602c041fd91133b662c35 (diff)
downloadbuildroot-novena-4ee9d569f9ae5da199b6e64a45d83dc6aa9c78ce.tar.gz
buildroot-novena-4ee9d569f9ae5da199b6e64a45d83dc6aa9c78ce.zip
uClibc: drop BR2_PROGRAM_INVOCATION option
Remove the BR option and enable the configuration setting in the uClibc defconfigs. The BR2_PROGRAM_INVOCATION option only adds very little overhead to uClibc, and we have a number of packages needing it, so simply always enable it - Simplifying the kconfig logic and the number of choices users have to make. Signed-off-by: Peter Korsgaard <jacmet@sunsite.dk>
Diffstat (limited to 'toolchain/toolchain-crosstool-ng')
-rw-r--r--toolchain/toolchain-crosstool-ng/Config.in12
-rw-r--r--toolchain/toolchain-crosstool-ng/crosstool-ng.mk7
-rw-r--r--toolchain/toolchain-crosstool-ng/uClibc.config3
3 files changed, 2 insertions, 20 deletions
diff --git a/toolchain/toolchain-crosstool-ng/Config.in b/toolchain/toolchain-crosstool-ng/Config.in
index 3cac8088a..2d1e801c4 100644
--- a/toolchain/toolchain-crosstool-ng/Config.in
+++ b/toolchain/toolchain-crosstool-ng/Config.in
@@ -17,7 +17,6 @@ config BR2_TOOLCHAIN_CTNG_eglibc
select BR2_INET_RPC
select BR2_ENABLE_LOCALE
select BR2_USE_WCHAR
- select BR2_PROGRAM_INVOCATION
config BR2_TOOLCHAIN_CTNG_glibc
bool "glibc"
@@ -26,7 +25,6 @@ config BR2_TOOLCHAIN_CTNG_glibc
select BR2_INET_RPC
select BR2_ENABLE_LOCALE
select BR2_USE_WCHAR
- select BR2_PROGRAM_INVOCATION
endchoice # C library
@@ -89,16 +87,6 @@ config BR2_TOOLCHAIN_CTNG_uClibc_LOCALE
Enable this option if you want your toolchain to support
localization and internationalization.
-config BR2_TOOLCHAIN_CTNG_uClibc_PROGRAM_INVOCATION
- bool "Enable 'program invocation name' support"
- select BR2_PROGRAM_INVOCATION
- help
- Enable this option if you want your toolchain to support the
- GNU-specific program_invocation_name and
- program_invocation_short_name strings. Some GNU packages
- (like tar and coreutils) utilize these for extra useful
- output, but in general are not required.
-
endif # BR2_TOOLCHAIN_CTNG_uClibc
config BR2_TOOLCHAIN_CTNG_CXX
diff --git a/toolchain/toolchain-crosstool-ng/crosstool-ng.mk b/toolchain/toolchain-crosstool-ng/crosstool-ng.mk
index ec6e1889b..912bb06b2 100644
--- a/toolchain/toolchain-crosstool-ng/crosstool-ng.mk
+++ b/toolchain/toolchain-crosstool-ng/crosstool-ng.mk
@@ -305,13 +305,6 @@ else
CTNG_FIX_DOT_CONFIG_LIBC_SED += s:^(UCLIBC_HAS_RPC)=.*:\# \1 is not set:;
endif
-# Handle the program_invocation_name option
-ifneq ($(call qstrip,$(BR2_PROGRAM_INVOCATION)),)
-CTNG_FIX_DOT_CONFIG_LIBC_SED += s:^\# (UCLIBC_HAS_PROGRAM_INVOCATION_NAME) is not set:\1=y:;
-else
-CTNG_FIX_DOT_CONFIG_LIBC_SED += s:^(UCLIBC_HAS_PROGRAM_INVOCATION_NAME)=y:\# \1 is not set:;
-endif
-
# Instruct CT-NG's .config where to find the uClibc's .config
CTNG_FIX_DOT_CONFIG_PATHS_SED += s:^(CT_LIBC_UCLIBC_CONFIG_FILE)=.*:\1="$(CTNG_DIR)/libc.config":;
diff --git a/toolchain/toolchain-crosstool-ng/uClibc.config b/toolchain/toolchain-crosstool-ng/uClibc.config
index f1163ae84..76a342746 100644
--- a/toolchain/toolchain-crosstool-ng/uClibc.config
+++ b/toolchain/toolchain-crosstool-ng/uClibc.config
@@ -109,7 +109,8 @@ UCLIBC_DYNAMIC_ATEXIT=y
# UCLIBC_SUSV3_LEGACY_MACROS is not set
# UCLIBC_HAS_STUBS is not set
UCLIBC_HAS_SHADOW=y
-# UCLIBC_HAS_PROGRAM_INVOCATION_NAME is not set
+UCLIBC_HAS_PROGRAM_INVOCATION_NAME=y
+UCLIBC_HAS___PROGNAME=y
UCLIBC_HAS_PTY=y
ASSUME_DEVPTS=y
UNIX98PTY_ONLY=y