summaryrefslogtreecommitdiffstats
path: root/toolchain
diff options
context:
space:
mode:
authorPeter Korsgaard <jacmet@sunsite.dk>2011-07-27 11:51:47 +0200
committerPeter Korsgaard <jacmet@sunsite.dk>2011-07-27 11:56:53 +0200
commit4ee9d569f9ae5da199b6e64a45d83dc6aa9c78ce (patch)
tree4104eb52b3319136dfa220d693ccf17919b75b3f /toolchain
parent213bbe9a2281f47eb1f602c041fd91133b662c35 (diff)
downloadbuildroot-novena-4ee9d569f9ae5da199b6e64a45d83dc6aa9c78ce.tar.gz
buildroot-novena-4ee9d569f9ae5da199b6e64a45d83dc6aa9c78ce.zip
uClibc: drop BR2_PROGRAM_INVOCATION option
Remove the BR option and enable the configuration setting in the uClibc defconfigs. The BR2_PROGRAM_INVOCATION option only adds very little overhead to uClibc, and we have a number of packages needing it, so simply always enable it - Simplifying the kconfig logic and the number of choices users have to make. Signed-off-by: Peter Korsgaard <jacmet@sunsite.dk>
Diffstat (limited to 'toolchain')
-rw-r--r--toolchain/helpers.mk2
-rw-r--r--toolchain/toolchain-buildroot/Config.in.210
-rw-r--r--toolchain/toolchain-common.in3
-rw-r--r--toolchain/toolchain-crosstool-ng/Config.in12
-rw-r--r--toolchain/toolchain-crosstool-ng/crosstool-ng.mk7
-rw-r--r--toolchain/toolchain-crosstool-ng/uClibc.config3
-rw-r--r--toolchain/toolchain-external/Config.in10
-rw-r--r--toolchain/uClibc/uClibc-0.9.30.config2
-rw-r--r--toolchain/uClibc/uClibc-0.9.31.config4
-rw-r--r--toolchain/uClibc/uClibc-0.9.32.config4
-rw-r--r--toolchain/uClibc/uClibc-snapshot.config4
-rw-r--r--toolchain/uClibc/uclibc.mk7
12 files changed, 9 insertions, 59 deletions
diff --git a/toolchain/helpers.mk b/toolchain/helpers.mk
index 13dbebbee..123720b87 100644
--- a/toolchain/helpers.mk
+++ b/toolchain/helpers.mk
@@ -148,7 +148,6 @@ check_glibc = \
$(call check_glibc_feature,BR2_ENABLE_LOCALE,Locale support) ;\
$(call check_glibc_feature,BR2_USE_MMU,MMU support) ;\
$(call check_glibc_feature,BR2_USE_WCHAR,Wide char support) ;\
- $(call check_glibc_feature,BR2_PROGRAM_INVOCATION,Program invocation support)
#
# Check the conformity of Buildroot configuration with regard to the
@@ -194,7 +193,6 @@ check_uclibc = \
$(call check_uclibc_feature,__UCLIBC_HAS_RPC__,BR2_INET_RPC,$${UCLIBC_CONFIG_FILE},RPC support) ;\
$(call check_uclibc_feature,__UCLIBC_HAS_LOCALE__,BR2_ENABLE_LOCALE,$${UCLIBC_CONFIG_FILE},Locale support) ;\
$(call check_uclibc_feature,__UCLIBC_HAS_WCHAR__,BR2_USE_WCHAR,$${UCLIBC_CONFIG_FILE},Wide char support) ;\
- $(call check_uclibc_feature,__UCLIBC_HAS_PROGRAM_INVOCATION_NAME__,BR2_PROGRAM_INVOCATION,$${UCLIBC_CONFIG_FILE},Program invocation support) ;\
$(call check_uclibc_feature,__UCLIBC_HAS_THREADS__,BR2_TOOLCHAIN_HAS_THREADS,$${UCLIBC_CONFIG_FILE},Thread support)
#
diff --git a/toolchain/toolchain-buildroot/Config.in.2 b/toolchain/toolchain-buildroot/Config.in.2
index 5df188f5d..e3fe33784 100644
--- a/toolchain/toolchain-buildroot/Config.in.2
+++ b/toolchain/toolchain-buildroot/Config.in.2
@@ -41,16 +41,6 @@ config BR2_TOOLCHAIN_BUILDROOT_LOCALE
Enable this option if you want your toolchain to support
localization and internationalization.
-config BR2_TOOLCHAIN_BUILDROOT_PROGRAM_INVOCATION
- bool "Enable 'program invocation name' support"
- select BR2_PROGRAM_INVOCATION
- help
- Enable this option if you want your toolchain to support the
- GNU-specific program_invocation_name and
- program_invocation_short_name strings. Some GNU packages
- (like tar and coreutils) utilize these for extra useful
- output, but in general are not required.
-
config BR2_TOOLCHAIN_BUILDROOT_CXX
bool "Enable C++ support"
select BR2_INSTALL_LIBSTDCPP
diff --git a/toolchain/toolchain-common.in b/toolchain/toolchain-common.in
index bbb7be627..2d1100809 100644
--- a/toolchain/toolchain-common.in
+++ b/toolchain/toolchain-common.in
@@ -20,9 +20,6 @@ config BR2_USE_WCHAR
config BR2_ENABLE_LOCALE
bool
-config BR2_PROGRAM_INVOCATION
- bool
-
config BR2_INSTALL_LIBSTDCPP
bool
diff --git a/toolchain/toolchain-crosstool-ng/Config.in b/toolchain/toolchain-crosstool-ng/Config.in
index 3cac8088a..2d1e801c4 100644
--- a/toolchain/toolchain-crosstool-ng/Config.in
+++ b/toolchain/toolchain-crosstool-ng/Config.in
@@ -17,7 +17,6 @@ config BR2_TOOLCHAIN_CTNG_eglibc
select BR2_INET_RPC
select BR2_ENABLE_LOCALE
select BR2_USE_WCHAR
- select BR2_PROGRAM_INVOCATION
config BR2_TOOLCHAIN_CTNG_glibc
bool "glibc"
@@ -26,7 +25,6 @@ config BR2_TOOLCHAIN_CTNG_glibc
select BR2_INET_RPC
select BR2_ENABLE_LOCALE
select BR2_USE_WCHAR
- select BR2_PROGRAM_INVOCATION
endchoice # C library
@@ -89,16 +87,6 @@ config BR2_TOOLCHAIN_CTNG_uClibc_LOCALE
Enable this option if you want your toolchain to support
localization and internationalization.
-config BR2_TOOLCHAIN_CTNG_uClibc_PROGRAM_INVOCATION
- bool "Enable 'program invocation name' support"
- select BR2_PROGRAM_INVOCATION
- help
- Enable this option if you want your toolchain to support the
- GNU-specific program_invocation_name and
- program_invocation_short_name strings. Some GNU packages
- (like tar and coreutils) utilize these for extra useful
- output, but in general are not required.
-
endif # BR2_TOOLCHAIN_CTNG_uClibc
config BR2_TOOLCHAIN_CTNG_CXX
diff --git a/toolchain/toolchain-crosstool-ng/crosstool-ng.mk b/toolchain/toolchain-crosstool-ng/crosstool-ng.mk
index ec6e1889b..912bb06b2 100644
--- a/toolchain/toolchain-crosstool-ng/crosstool-ng.mk
+++ b/toolchain/toolchain-crosstool-ng/crosstool-ng.mk
@@ -305,13 +305,6 @@ else
CTNG_FIX_DOT_CONFIG_LIBC_SED += s:^(UCLIBC_HAS_RPC)=.*:\# \1 is not set:;
endif
-# Handle the program_invocation_name option
-ifneq ($(call qstrip,$(BR2_PROGRAM_INVOCATION)),)
-CTNG_FIX_DOT_CONFIG_LIBC_SED += s:^\# (UCLIBC_HAS_PROGRAM_INVOCATION_NAME) is not set:\1=y:;
-else
-CTNG_FIX_DOT_CONFIG_LIBC_SED += s:^(UCLIBC_HAS_PROGRAM_INVOCATION_NAME)=y:\# \1 is not set:;
-endif
-
# Instruct CT-NG's .config where to find the uClibc's .config
CTNG_FIX_DOT_CONFIG_PATHS_SED += s:^(CT_LIBC_UCLIBC_CONFIG_FILE)=.*:\1="$(CTNG_DIR)/libc.config":;
diff --git a/toolchain/toolchain-crosstool-ng/uClibc.config b/toolchain/toolchain-crosstool-ng/uClibc.config
index f1163ae84..76a342746 100644
--- a/toolchain/toolchain-crosstool-ng/uClibc.config
+++ b/toolchain/toolchain-crosstool-ng/uClibc.config
@@ -109,7 +109,8 @@ UCLIBC_DYNAMIC_ATEXIT=y
# UCLIBC_SUSV3_LEGACY_MACROS is not set
# UCLIBC_HAS_STUBS is not set
UCLIBC_HAS_SHADOW=y
-# UCLIBC_HAS_PROGRAM_INVOCATION_NAME is not set
+UCLIBC_HAS_PROGRAM_INVOCATION_NAME=y
+UCLIBC_HAS___PROGNAME=y
UCLIBC_HAS_PTY=y
ASSUME_DEVPTS=y
UNIX98PTY_ONLY=y
diff --git a/toolchain/toolchain-external/Config.in b/toolchain/toolchain-external/Config.in
index 8cd37d4b5..bedbb53d8 100644
--- a/toolchain/toolchain-external/Config.in
+++ b/toolchain/toolchain-external/Config.in
@@ -173,7 +173,6 @@ config BR2_TOOLCHAIN_EXTERNAL_BLACKFIN_UCLINUX_2010RC1
select BR2_INET_IPV6
select BR2_INET_RPC
select BR2_USE_WCHAR
- select BR2_PROGRAM_INVOCATION
select BR2_TOOLCHAIN_HAS_THREADS
help
Toolchain for the Blackfin architecture, from
@@ -231,7 +230,6 @@ config BR2_TOOLCHAIN_EXTERNAL_GLIBC
select BR2_INET_RPC
select BR2_USE_WCHAR
select BR2_ENABLE_LOCALE
- select BR2_PROGRAM_INVOCATION
select BR2_TOOLCHAIN_HAS_THREADS
select BR2_TOOLCHAIN_HAS_SHADOW_PASSWORDS
@@ -300,14 +298,6 @@ config BR2_TOOLCHAIN_EXTERNAL_LOCALE
support. If you don't know, leave the default value,
Buildroot will tell you if it's correct or not.
-config BR2_TOOLCHAIN_EXTERNAL_PROGRAM_INVOCATION
- bool "Toolchain has program invocation support?"
- select BR2_PROGRAM_INVOCATION
- help
- Select this option if your external toolchain has program
- invocation support. If you don't know, leave the default
- value, Buildroot will tell you if it's correct or not.
-
config BR2_TOOLCHAIN_EXTERNAL_HAS_THREADS
bool "Toolchain has threads support?"
select BR2_TOOLCHAIN_HAS_THREADS
diff --git a/toolchain/uClibc/uClibc-0.9.30.config b/toolchain/uClibc/uClibc-0.9.30.config
index 2202b9e14..49ac3ef4c 100644
--- a/toolchain/uClibc/uClibc-0.9.30.config
+++ b/toolchain/uClibc/uClibc-0.9.30.config
@@ -82,7 +82,7 @@ UCLIBC_DYNAMIC_ATEXIT=y
# UCLIBC_SUSV3_LEGACY_MACROS is not set
# UCLIBC_HAS_STUBS is not set
UCLIBC_HAS_SHADOW=y
-# UCLIBC_HAS_PROGRAM_INVOCATION_NAME is not set
+UCLIBC_HAS_PROGRAM_INVOCATION_NAME=y
UCLIBC_HAS___PROGNAME=y
UCLIBC_HAS_PTY=y
ASSUME_DEVPTS=y
diff --git a/toolchain/uClibc/uClibc-0.9.31.config b/toolchain/uClibc/uClibc-0.9.31.config
index 60b462806..80210c5df 100644
--- a/toolchain/uClibc/uClibc-0.9.31.config
+++ b/toolchain/uClibc/uClibc-0.9.31.config
@@ -89,8 +89,8 @@ UCLIBC_SUSV3_LEGACY=y
UCLIBC_SUSV4_LEGACY=y
# UCLIBC_HAS_STUBS is not set
UCLIBC_HAS_SHADOW=y
-# UCLIBC_HAS_PROGRAM_INVOCATION_NAME is not set
-# UCLIBC_HAS___PROGNAME is not set
+UCLIBC_HAS_PROGRAM_INVOCATION_NAME=y
+UCLIBC_HAS___PROGNAME=y
UCLIBC_HAS_PTY=y
ASSUME_DEVPTS=y
UNIX98PTY_ONLY=y
diff --git a/toolchain/uClibc/uClibc-0.9.32.config b/toolchain/uClibc/uClibc-0.9.32.config
index 5a7b52a9a..e9f942d63 100644
--- a/toolchain/uClibc/uClibc-0.9.32.config
+++ b/toolchain/uClibc/uClibc-0.9.32.config
@@ -113,8 +113,8 @@ UCLIBC_SUSV4_LEGACY=y
# UCLIBC_STRICT_HEADERS is not set
# UCLIBC_HAS_STUBS is not set
UCLIBC_HAS_SHADOW=y
-# UCLIBC_HAS_PROGRAM_INVOCATION_NAME is not set
-# UCLIBC_HAS___PROGNAME is not set
+UCLIBC_HAS_PROGRAM_INVOCATION_NAME=y
+UCLIBC_HAS___PROGNAME=y
UCLIBC_HAS_PTY=y
ASSUME_DEVPTS=y
UNIX98PTY_ONLY=y
diff --git a/toolchain/uClibc/uClibc-snapshot.config b/toolchain/uClibc/uClibc-snapshot.config
index 34ec0ff01..bff758469 100644
--- a/toolchain/uClibc/uClibc-snapshot.config
+++ b/toolchain/uClibc/uClibc-snapshot.config
@@ -113,8 +113,8 @@ UCLIBC_SUSV4_LEGACY=y
# UCLIBC_STRICT_HEADERS is not set
# UCLIBC_HAS_STUBS is not set
UCLIBC_HAS_SHADOW=y
-# UCLIBC_HAS_PROGRAM_INVOCATION_NAME is not set
-# UCLIBC_HAS___PROGNAME is not set
+UCLIBC_HAS_PROGRAM_INVOCATION_NAME=y
+UCLIBC_HAS___PROGNAME=y
UCLIBC_HAS_PTY=y
ASSUME_DEVPTS=y
UNIX98PTY_ONLY=y
diff --git a/toolchain/uClibc/uclibc.mk b/toolchain/uClibc/uclibc.mk
index 3173ef4bb..e74012f61 100644
--- a/toolchain/uClibc/uclibc.mk
+++ b/toolchain/uClibc/uclibc.mk
@@ -318,13 +318,6 @@ ifeq ($(BR2_USE_WCHAR),y)
else
$(SED) 's,^.*UCLIBC_HAS_WCHAR.*,UCLIBC_HAS_WCHAR=n,g' $(UCLIBC_DIR)/.oldconfig
endif
-ifeq ($(BR2_PROGRAM_INVOCATION),y)
- $(SED) 's,^.*UCLIBC_HAS_PROGRAM_INVOCATION_NAME.*,UCLIBC_HAS_PROGRAM_INVOCATION_NAME=y,g' $(UCLIBC_DIR)/.oldconfig
- $(SED) 's,^.*UCLIBC_HAS___PROGNAME.*,UCLIBC_HAS___PROGNAME=y,g' $(UCLIBC_DIR)/.oldconfig
-else
- $(SED) 's,^.*UCLIBC_HAS_PROGRAM_INVOCATION_NAME.*,UCLIBC_HAS_PROGRAM_INVOCATION_NAME=n,g' $(UCLIBC_DIR)/.oldconfig
- $(SED) 's,^.*UCLIBC_HAS___PROGNAME.*,UCLIBC_HAS___PROGNAME=n,g' $(UCLIBC_DIR)/.oldconfig
-endif
ifeq ("$(KERNEL_ARCH)","i386")
/bin/echo "# CONFIG_GENERIC_386 is not set" >> $(UCLIBC_DIR)/.oldconfig
/bin/echo "# CONFIG_386 is not set" >> $(UCLIBC_DIR)/.oldconfig