summaryrefslogtreecommitdiffstats
path: root/toolchain/helpers.mk
diff options
context:
space:
mode:
authorThomas Petazzoni <thomas.petazzoni@free-electrons.com>2010-12-13 17:27:41 +0100
committerPeter Korsgaard <jacmet@sunsite.dk>2010-12-13 22:04:35 +0100
commit6b578c8d73b6403e3be8bddf611fb1059d7c2f4b (patch)
treede57da65f9460e3c9edb0599a859809384452580 /toolchain/helpers.mk
parent01b434b27a24652cf1ad2d77aeba8f55bac61e1c (diff)
downloadbuildroot-novena-6b578c8d73b6403e3be8bddf611fb1059d7c2f4b.tar.gz
buildroot-novena-6b578c8d73b6403e3be8bddf611fb1059d7c2f4b.zip
toolchain: rework C++ options
Instead of having BR2_GCC_CROSS_CXX and BR2_INSTALL_LIBSTDCPP, with BR2_GCC_CROSS_CXX not being visible (and therefore being useless), let's just keep BR2_INSTALL_LIBSTDCPP to enable C++ in the toolchain and install C++ libraries on the target. We also take that opportunity to make BR2_INSTALL_LIBSTDCPP an hidden option, which is selected by an option in Buildroot toolchain support or an option in External toolchain support, just as we did for other toolchain features. Some work definitely remains to be done : - The name BR2_INSTALL_LIBSTDCPP is ugly, but we keep it for the moment in order to avoid changing all packages. - We should clarify the other language-related options (Fortran, Java, Objective-C, etc.). Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com> Reviewed-by: "Yann E. MORIN" <yann.morin.1998@anciens.enib.fr> Signed-off-by: Peter Korsgaard <jacmet@sunsite.dk>
Diffstat (limited to 'toolchain/helpers.mk')
-rw-r--r--toolchain/helpers.mk2
1 files changed, 1 insertions, 1 deletions
diff --git a/toolchain/helpers.mk b/toolchain/helpers.mk
index 24f379d49..33f048405 100644
--- a/toolchain/helpers.mk
+++ b/toolchain/helpers.mk
@@ -220,7 +220,7 @@ check_arm_abi = \
check_cplusplus = \
$(TARGET_CXX) -v > /dev/null 2>&1 ; \
if test $$? -ne 0 ; then \
- echo "BR2_INSTALL_LIBSTDCPP is selected but C++ support not available in external toolchain" ; \
+ echo "C++ support is selected but is not available in external toolchain" ; \
exit 1 ; \
fi