summaryrefslogtreecommitdiffstats
path: root/toolchain/helpers.mk
diff options
context:
space:
mode:
authorThomas Petazzoni <thomas.petazzoni@free-electrons.com>2010-12-13 17:27:40 +0100
committerPeter Korsgaard <jacmet@sunsite.dk>2010-12-13 22:02:32 +0100
commit01b434b27a24652cf1ad2d77aeba8f55bac61e1c (patch)
treef758a638f259c5c6bd80cf82d6f600a4bd88739e /toolchain/helpers.mk
parent6c492d5e7be51e4f1031139883acd03f78881e49 (diff)
downloadbuildroot-novena-01b434b27a24652cf1ad2d77aeba8f55bac61e1c.tar.gz
buildroot-novena-01b434b27a24652cf1ad2d77aeba8f55bac61e1c.zip
toolchain: remove toolchain-specific stripping
We already handle the stripping of libraries in $(TARGET_DIR) at the global level, so there's no need to have toolchain-specific option and code for this. Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com> Reviewed-by: "Yann E. MORIN" <yann.morin.1998@anciens.enib.fr> Signed-off-by: Peter Korsgaard <jacmet@sunsite.dk>
Diffstat (limited to 'toolchain/helpers.mk')
-rw-r--r--toolchain/helpers.mk9
1 files changed, 0 insertions, 9 deletions
diff --git a/toolchain/helpers.mk b/toolchain/helpers.mk
index 43c6db324..24f379d49 100644
--- a/toolchain/helpers.mk
+++ b/toolchain/helpers.mk
@@ -15,13 +15,11 @@
# $1: arch specific sysroot directory
# $2: library name
# $3: destination directory of the libary, relative to $(TARGET_DIR)
-# $4: strip (y|n), default is to strip
#
copy_toolchain_lib_root = \
ARCH_SYSROOT_DIR="$(strip $1)"; \
LIB="$(strip $2)"; \
DESTDIR="$(strip $3)" ; \
- STRIP="$(strip $4)"; \
\
LIBS=`(cd $${ARCH_SYSROOT_DIR}; \
find -L . -path "./lib/$${LIB}.*" -o \
@@ -39,13 +37,6 @@ copy_toolchain_lib_root = \
cp -d $${FULLPATH} $(TARGET_DIR)/$${DESTDIR}/; \
elif test -f $${FULLPATH}; then \
$(INSTALL) -D -m0755 $${FULLPATH} $(TARGET_DIR)/$${DESTDIR}/$${LIB}; \
- case "$${STRIP}" in \
- (0 | n | no) \
-;; \
- (*) \
- $(TARGET_CROSS)strip "$(TARGET_DIR)/$${DESTDIR}/$${LIB}"; \
-;; \
- esac; \
else \
exit -1; \
fi; \