summaryrefslogtreecommitdiffstats
path: root/package/usb_modeswitch/usb_modeswitch-1.0.7-build-system-fix.patch
diff options
context:
space:
mode:
authorThomas Petazzoni <thomas.petazzoni@free-electrons.com>2010-04-06 21:50:52 +0200
committerThomas Petazzoni <thomas.petazzoni@free-electrons.com>2010-04-06 21:55:30 +0200
commit6caec6f3b3aecf41c3a051ffa4b5d9a2e41775ca (patch)
treeee524c8c2efa437c3214fcb83fcdfeb50cf88420 /package/usb_modeswitch/usb_modeswitch-1.0.7-build-system-fix.patch
parente237c9935796445434a7888b9fe2aa84e3e7975a (diff)
downloadbuildroot-novena-6caec6f3b3aecf41c3a051ffa4b5d9a2e41775ca.tar.gz
buildroot-novena-6caec6f3b3aecf41c3a051ffa4b5d9a2e41775ca.zip
usb_modeswitch: use GENTARGETS instead of AUTOTARGETS
usb_modeswitch build system is just a simple Makefile, so the GENTARGETS infrastructure is more appropriate than the AUTOTARGETS infrastructure. The build system is slightly fixed through a small patch, that replaces the previous "nostrip" patch. The latest version of usb_modeswitch is 1.1.1, but it now relies on udev and requires TCL to operate. Someone actually using usb_modeswitch would probably be at a better place to do this version bump. Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
Diffstat (limited to 'package/usb_modeswitch/usb_modeswitch-1.0.7-build-system-fix.patch')
-rw-r--r--package/usb_modeswitch/usb_modeswitch-1.0.7-build-system-fix.patch29
1 files changed, 29 insertions, 0 deletions
diff --git a/package/usb_modeswitch/usb_modeswitch-1.0.7-build-system-fix.patch b/package/usb_modeswitch/usb_modeswitch-1.0.7-build-system-fix.patch
new file mode 100644
index 000000000..71dbc7a6d
--- /dev/null
+++ b/package/usb_modeswitch/usb_modeswitch-1.0.7-build-system-fix.patch
@@ -0,0 +1,29 @@
+---
+ Makefile | 7 +++----
+ 1 file changed, 3 insertions(+), 4 deletions(-)
+
+Index: usb_modeswitch-1.0.7/Makefile
+===================================================================
+--- usb_modeswitch-1.0.7.orig/Makefile
++++ usb_modeswitch-1.0.7/Makefile
+@@ -1,8 +1,8 @@
+ PROG = usb_modeswitch
+ VERS = 1.0.7
+ STRIP = strip
+-CC = gcc
+-CCFLAGS = -l usb -Wall
++CC ?= gcc
++CFLAGS += -l usb -Wall
+ RM = /bin/rm -f
+ OBJS = usb_modeswitch.c
+ PREFIX = $(DESTDIR)/usr
+@@ -12,8 +12,7 @@
+ .PHONY: clean
+ all: $(PROG)
+ $(PROG): $(OBJS)
+- $(CC) $(CCFLAGS) -o $(PROG) $(OBJS)
+- $(STRIP) $(PROG)
++ $(CC) $(CFLAGS) -o $(PROG) $(OBJS)
+
+ clean:
+ $(RM) ./usb_modeswitch