summaryrefslogtreecommitdiffstats
path: root/package/usb_modeswitch
diff options
context:
space:
mode:
authorThomas Petazzoni <thomas.petazzoni@free-electrons.com>2010-04-06 21:50:52 +0200
committerThomas Petazzoni <thomas.petazzoni@free-electrons.com>2010-04-06 21:55:30 +0200
commit6caec6f3b3aecf41c3a051ffa4b5d9a2e41775ca (patch)
treeee524c8c2efa437c3214fcb83fcdfeb50cf88420 /package/usb_modeswitch
parente237c9935796445434a7888b9fe2aa84e3e7975a (diff)
downloadbuildroot-novena-6caec6f3b3aecf41c3a051ffa4b5d9a2e41775ca.tar.gz
buildroot-novena-6caec6f3b3aecf41c3a051ffa4b5d9a2e41775ca.zip
usb_modeswitch: use GENTARGETS instead of AUTOTARGETS
usb_modeswitch build system is just a simple Makefile, so the GENTARGETS infrastructure is more appropriate than the AUTOTARGETS infrastructure. The build system is slightly fixed through a small patch, that replaces the previous "nostrip" patch. The latest version of usb_modeswitch is 1.1.1, but it now relies on udev and requires TCL to operate. Someone actually using usb_modeswitch would probably be at a better place to do this version bump. Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
Diffstat (limited to 'package/usb_modeswitch')
-rw-r--r--package/usb_modeswitch/usb_modeswitch-1.0.7-build-system-fix.patch29
-rw-r--r--package/usb_modeswitch/usb_modeswitch-nostrip.patch11
-rw-r--r--package/usb_modeswitch/usb_modeswitch.mk26
3 files changed, 41 insertions, 25 deletions
diff --git a/package/usb_modeswitch/usb_modeswitch-1.0.7-build-system-fix.patch b/package/usb_modeswitch/usb_modeswitch-1.0.7-build-system-fix.patch
new file mode 100644
index 000000000..71dbc7a6d
--- /dev/null
+++ b/package/usb_modeswitch/usb_modeswitch-1.0.7-build-system-fix.patch
@@ -0,0 +1,29 @@
+---
+ Makefile | 7 +++----
+ 1 file changed, 3 insertions(+), 4 deletions(-)
+
+Index: usb_modeswitch-1.0.7/Makefile
+===================================================================
+--- usb_modeswitch-1.0.7.orig/Makefile
++++ usb_modeswitch-1.0.7/Makefile
+@@ -1,8 +1,8 @@
+ PROG = usb_modeswitch
+ VERS = 1.0.7
+ STRIP = strip
+-CC = gcc
+-CCFLAGS = -l usb -Wall
++CC ?= gcc
++CFLAGS += -l usb -Wall
+ RM = /bin/rm -f
+ OBJS = usb_modeswitch.c
+ PREFIX = $(DESTDIR)/usr
+@@ -12,8 +12,7 @@
+ .PHONY: clean
+ all: $(PROG)
+ $(PROG): $(OBJS)
+- $(CC) $(CCFLAGS) -o $(PROG) $(OBJS)
+- $(STRIP) $(PROG)
++ $(CC) $(CFLAGS) -o $(PROG) $(OBJS)
+
+ clean:
+ $(RM) ./usb_modeswitch
diff --git a/package/usb_modeswitch/usb_modeswitch-nostrip.patch b/package/usb_modeswitch/usb_modeswitch-nostrip.patch
deleted file mode 100644
index 3bb8e8d38..000000000
--- a/package/usb_modeswitch/usb_modeswitch-nostrip.patch
+++ /dev/null
@@ -1,11 +0,0 @@
-diff -Nura usb_modeswitch-1.0.1/Makefile usb_modeswitch-1.0.1.nostrip/Makefile
---- usb_modeswitch-1.0.1/Makefile 2009-04-15 16:15:17.000000000 -0300
-+++ usb_modeswitch-1.0.1.nostrip/Makefile 2009-06-10 10:02:05.000000000 -0300
-@@ -13,7 +13,6 @@
- all: $(PROG)
- $(PROG): $(OBJS)
- $(CC) $(CCFLAGS) -o $(PROG) $(OBJS)
-- $(STRIP) $(PROG)
-
- clean:
- $(RM) ./usb_modeswitch
diff --git a/package/usb_modeswitch/usb_modeswitch.mk b/package/usb_modeswitch/usb_modeswitch.mk
index 377bc3b91..d84ccc2bf 100644
--- a/package/usb_modeswitch/usb_modeswitch.mk
+++ b/package/usb_modeswitch/usb_modeswitch.mk
@@ -7,22 +7,20 @@
USB_MODESWITCH_VERSION = 1.0.7
USB_MODESWITCH_SOURCE = usb_modeswitch-$(USB_MODESWITCH_VERSION).tar.bz2
USB_MODESWITCH_SITE = http://www.draisberghof.de/usb_modeswitch
-USB_MODESWITCH_INSTALL_TARGET_OPT = DESTDIR=$(TARGET_DIR) install
USB_MODESWITCH_DEPENDENCIES = libusb-compat
-USB_MODESWITCH_MAKE_OPT = CC="$(TARGET_CC)" OPTS="$(TARGET_CFLAGS)"
-$(eval $(call AUTOTARGETS,package,usb_modeswitch))
+define USB_MODESWITCH_BUILD_CMDS
+ rm $(@D)/usb_modeswitch
+ $(TARGET_CONFIGURE_OPTS) $(TARGET_MAKE_ENV) $(MAKE) -C $(@D)
+endef
-$(USB_MODESWITCH_TARGET_CONFIGURE):
- rm -f $(USB_MODESWITCH_DIR)/usb_modeswitch
- touch $@
+define USB_MODESWITCH_INSTALL_TARGET_CMDS
+ $(TARGET_MAKE_ENV) $(MAKE) -C $(@D) DESTDIR=$(TARGET_DIR) install
+endef
-$(USB_MODESWITCH_HOOK_POST_INSTALL):
- chmod a-x $(TARGET_DIR)/etc/usb_modeswitch.conf
- touch $@
+define USB_MODESWITCH_CLEAN_CMDS
+ rm -f $(TARGET_DIR)/usr/sbin/usb_modeswitch
+ rm -f $(TARGET_DIR)/etc/usb_modeswitch.conf
+endef
-$(USB_MODESWITCH_TARGET_UNINSTALL):
- $(call MESSAGE,"Uninstalling")
- rm -f $(TARGET_DIR)/usr/sbin/usb_modeswitch
- rm -f $(TARGET_DIR)/etc/usb_modeswitch.conf
- rm -f $(USB_MODESWITCH_TARGET_INSTALL_TARGET) $(USB_MODESWITCH_HOOK_POST_INSTALL)
+$(eval $(call GENTARGETS,package,usb_modeswitch))