summaryrefslogtreecommitdiffstats
path: root/package/tinyhttpd
diff options
context:
space:
mode:
authorPeter Korsgaard <jacmet@sunsite.dk>2012-04-03 22:51:05 +0200
committerPeter Korsgaard <jacmet@sunsite.dk>2012-04-03 22:51:05 +0200
commitd58777fdf0d18da7c08f6b604d36f85aae2ec5bb (patch)
tree054dbc75d5cc9a6059bbd3d73f34438474565448 /package/tinyhttpd
parent9afba4fdc672662c39f088b51c2ee939679d51a2 (diff)
downloadbuildroot-novena-d58777fdf0d18da7c08f6b604d36f85aae2ec5bb.tar.gz
buildroot-novena-d58777fdf0d18da7c08f6b604d36f85aae2ec5bb.zip
tinyhttpd: fix initscript, install as /usr/sbin/tinyhttpd
The init script was expecting the binary to be called tinyhttpd, but httpd was used. Fix it to install as tinyhttpd as httpd will conflict with other web servers (E.G. the busybox one). Signed-off-by: Peter Korsgaard <jacmet@sunsite.dk>
Diffstat (limited to 'package/tinyhttpd')
-rw-r--r--package/tinyhttpd/tinyhttpd.mk4
1 files changed, 2 insertions, 2 deletions
diff --git a/package/tinyhttpd/tinyhttpd.mk b/package/tinyhttpd/tinyhttpd.mk
index 6bc37d46e..9b06589d3 100644
--- a/package/tinyhttpd/tinyhttpd.mk
+++ b/package/tinyhttpd/tinyhttpd.mk
@@ -12,14 +12,14 @@ define TINYHTTPD_BUILD_CMDS
endef
define TINYHTTPD_INSTALL_TARGET_CMDS
- $(INSTALL) -m 0755 -D $(@D)/httpd $(TARGET_DIR)/usr/sbin/httpd
+ $(INSTALL) -m 0755 -D $(@D)/httpd $(TARGET_DIR)/usr/sbin/tinyhttpd
$(INSTALL) -m 0755 -D package/tinyhttpd/S85tinyhttpd \
$(TARGET_DIR)/etc/init.d/S85tinyhttpd
mkdir -p $(TARGET_DIR)/var/www
endef
define TINYHTTPD_CLEAN_CMDS
- rm -f $(TARGET_DIR)/usr/sbin/httpd
+ rm -f $(TARGET_DIR)/usr/sbin/tinyhttpd
rm -f $(TARGET_DIR)/etc/init.d/S85tinyhttpd
endef