summaryrefslogtreecommitdiffstats
path: root/package/sed
diff options
context:
space:
mode:
authorEric Andersen <andersen@codepoet.org>2004-10-09 02:49:33 +0000
committerEric Andersen <andersen@codepoet.org>2004-10-09 02:49:33 +0000
commit44eedc5c44416a97b3f5ca03d596ec3c9fb29380 (patch)
tree96f605b4cd9934fc1d09319490c672aaab44ce2f /package/sed
parent73f7be82904f487d167493e76b415fbe5b5f8c5a (diff)
downloadbuildroot-novena-44eedc5c44416a97b3f5ca03d596ec3c9fb29380.tar.gz
buildroot-novena-44eedc5c44416a97b3f5ca03d596ec3c9fb29380.zip
facelift step number two
Diffstat (limited to 'package/sed')
-rw-r--r--package/sed/sed.mk87
-rwxr-xr-xpackage/sed/sedcheck.sh21
2 files changed, 91 insertions, 17 deletions
diff --git a/package/sed/sed.mk b/package/sed/sed.mk
index e197bca3e..108d4fe3a 100644
--- a/package/sed/sed.mk
+++ b/package/sed/sed.mk
@@ -7,14 +7,15 @@ SED_VER:=4.1.2
SED_SOURCE:=sed-$(SED_VER).tar.gz
SED_SITE:=ftp://ftp.gnu.org/gnu/sed
SED_CAT:=zcat
-SED_DIR:=$(BUILD_DIR)/sed-$(SED_VER)
+SED_DIR1:=$(TOOL_BUILD_DIR)/sed-$(SED_VER)
+SED_DIR2:=$(BUILD_DIR)/sed-$(SED_VER)
SED_BINARY:=sed/sed
SED_TARGET_BINARY:=bin/sed
-ifeq ($(BR2_LARGEFILE),y)
+ifeq ($(strip $(BUILD_WITH_LARGEFILE)),true)
SED_CPPFLAGS=-D_FILE_OFFSET_BITS=64
endif
SED:=$(STAGING_DIR)/bin/sed -i -e
-
+HOST_SED_TARGET=$(shell package/sed/sedcheck.sh)
$(DL_DIR)/$(SED_SOURCE):
mkdir -p $(DL_DIR)
@@ -25,15 +26,67 @@ sed-source: $(DL_DIR)/$(SED_SOURCE)
#############################################################
#
+# build sed for use on the host system
+#
+#############################################################
+$(SED_DIR1)/.unpacked: $(DL_DIR)/$(SED_SOURCE)
+ mkdir -p $(TOOL_BUILD_DIR)
+ mkdir -p $(STAGING_DIR)/bin;
+ $(SED_CAT) $(DL_DIR)/$(SED_SOURCE) | tar -C $(TOOL_BUILD_DIR) -xvf -
+ touch $(SED_DIR1)/.unpacked
+
+$(SED_DIR1)/.configured: $(SED_DIR1)/.unpacked
+ (cd $(SED_DIR1); rm -rf config.cache; \
+ ./configure \
+ --prefix=$(STAGING_DIR) \
+ --prefix=/usr \
+ );
+ touch $(SED_DIR1)/.configured
+
+$(SED_DIR1)/$(SED_BINARY): $(SED_DIR1)/.configured
+ $(MAKE) -C $(SED_DIR1)
+
+# This stuff is needed to work around GNU make deficiencies
+build-sed-host-binary: $(SED_DIR1)/$(SED_BINARY)
+ @if [ -L $(STAGING_DIR)/$(SED_TARGET_BINARY) ] ; then \
+ rm -f $(STAGING_DIR)/$(SED_TARGET_BINARY); fi;
+ @if [ ! -f $(STAGING_DIR)/$(SED_TARGET_BINARY) -o $(STAGING_DIR)/$(SED_TARGET_BINARY) \
+ -ot $(SED_DIR1)/$(SED_BINARY) ] ; then \
+ set -x; \
+ mkdir -p $(STAGING_DIR)/bin; \
+ $(MAKE) DESTDIR=$(STAGING_DIR) -C $(SED_DIR1) install; \
+ mv $(STAGING_DIR)/usr/bin/sed $(STAGING_DIR)/bin/; \
+ rm -rf $(STAGING_DIR)/share/locale $(STAGING_DIR)/usr/info \
+ $(STAGING_DIR)/usr/man $(STAGING_DIR)/usr/share/doc; fi
+
+use-sed-host-binary:
+ @if [ -x /usr/bin/sed ]; then SED="/usr/bin/sed"; else \
+ if [ -x /bin/sed ]; then SED="/bin/sed"; fi; fi; \
+ mkdir -p $(STAGING_DIR)/bin; \
+ rm -f $(STAGING_DIR)/$(SED_TARGET_BINARY); \
+ ln -s $$SED $(STAGING_DIR)/$(SED_TARGET_BINARY)
+
+host-sed: $(HOST_SED_TARGET)
+
+host-sed-clean:
+ $(MAKE) DESTDIR=$(STAGING_DIR) -C $(SED_DIR1) uninstall
+ -$(MAKE) -C $(SED_DIR1) clean
+
+host-sed-dirclean:
+ rm -rf $(SED_DIR1)
+
+
+#############################################################
+#
# build sed for use on the target system
#
#############################################################
-$(SED_DIR)/.unpacked: $(DL_DIR)/$(SED_SOURCE)
+$(SED_DIR2)/.unpacked: $(DL_DIR)/$(SED_SOURCE)
$(SED_CAT) $(DL_DIR)/$(SED_SOURCE) | tar -C $(BUILD_DIR) -xvf -
- touch $(SED_DIR)/.unpacked
+ touch $(SED_DIR2)/.unpacked
-$(SED_DIR)/.configured: $(SED_DIR)/.unpacked
- (cd $(SED_DIR); rm -rf config.cache; \
+$(SED_DIR2)/.configured: $(SED_DIR2)/.unpacked
+ (cd $(SED_DIR2); rm -rf config.cache; \
$(TARGET_CONFIGURE_OPTS) \
CFLAGS="$(TARGET_CFLAGS)" \
CPPFLAGS="$(SED_CFLAGS)" \
@@ -53,20 +106,20 @@ $(SED_DIR)/.configured: $(SED_DIR)/.unpacked
--infodir=/usr/info \
$(DISABLE_NLS) \
);
- touch $(SED_DIR)/.configured
+ touch $(SED_DIR2)/.configured
-$(SED_DIR)/$(SED_BINARY): $(SED_DIR)/.configured
- $(MAKE) CC=$(TARGET_CC) -C $(SED_DIR)
+$(SED_DIR2)/$(SED_BINARY): $(SED_DIR2)/.configured
+ $(MAKE) CC=$(TARGET_CC) -C $(SED_DIR2)
# This stuff is needed to work around GNU make deficiencies
-sed-target_binary: $(SED_DIR)/$(SED_BINARY)
+sed-target_binary: $(SED_DIR2)/$(SED_BINARY)
@if [ -L $(TARGET_DIR)/$(SED_TARGET_BINARY) ] ; then \
rm -f $(TARGET_DIR)/$(SED_TARGET_BINARY); fi;
- @if [ ! -f $(SED_DIR)/$(SED_BINARY) -o $(TARGET_DIR)/$(SED_TARGET_BINARY) \
- -ot $(SED_DIR)/$(SED_BINARY) ] ; then \
+ @if [ ! -f $(SED_DIR2)/$(SED_BINARY) -o $(TARGET_DIR)/$(SED_TARGET_BINARY) \
+ -ot $(SED_DIR2)/$(SED_BINARY) ] ; then \
set -x; \
- $(MAKE) DESTDIR=$(TARGET_DIR) CC=$(TARGET_CC) -C $(SED_DIR) install; \
+ $(MAKE) DESTDIR=$(TARGET_DIR) CC=$(TARGET_CC) -C $(SED_DIR2) install; \
mv $(TARGET_DIR)/usr/bin/sed $(TARGET_DIR)/bin/; \
rm -rf $(TARGET_DIR)/share/locale $(TARGET_DIR)/usr/info \
$(TARGET_DIR)/usr/man $(TARGET_DIR)/usr/share/doc; fi
@@ -74,10 +127,10 @@ sed-target_binary: $(SED_DIR)/$(SED_BINARY)
sed: uclibc sed-target_binary
sed-clean:
- $(MAKE) DESTDIR=$(TARGET_DIR) CC=$(TARGET_CC) -C $(SED_DIR) uninstall
- -$(MAKE) -C $(SED_DIR) clean
+ $(MAKE) DESTDIR=$(TARGET_DIR) CC=$(TARGET_CC) -C $(SED_DIR2) uninstall
+ -$(MAKE) -C $(SED_DIR2) clean
sed-dirclean:
- rm -rf $(SED_DIR)
+ rm -rf $(SED_DIR2)
diff --git a/package/sed/sedcheck.sh b/package/sed/sedcheck.sh
new file mode 100755
index 000000000..4d645b6ab
--- /dev/null
+++ b/package/sed/sedcheck.sh
@@ -0,0 +1,21 @@
+#!/bin/sh
+
+if [ -x /usr/bin/sed ]; then
+ SED="/usr/bin/sed";
+else
+ if [ -x /bin/sed ]; then
+ SED="/bin/sed";
+ fi;
+fi;
+
+echo "HELLO" > .sedtest
+$SED -i -e "s/HELLO/GOODBYE/" .sedtest >/dev/null 2>&1
+
+if [ $? != 0 ] ; then
+ echo build-sed-host-binary
+else
+ echo use-sed-host-binary
+fi;
+rm -f .sedtest
+
+