summaryrefslogtreecommitdiffstats
path: root/package/sdl_sound
diff options
context:
space:
mode:
authorPeter Korsgaard <jacmet@sunsite.dk>2010-07-04 08:56:00 +0200
committerPeter Korsgaard <jacmet@sunsite.dk>2010-07-04 08:57:09 +0200
commit5ba54aa10bb8936f3575e3b97916d299783cf858 (patch)
tree0986912b3d625f4aeeb838a4c449655ff2fa5abb /package/sdl_sound
parentd31046ec2667a109bae6e342d40d452cbd06b653 (diff)
downloadbuildroot-novena-5ba54aa10bb8936f3575e3b97916d299783cf858.tar.gz
buildroot-novena-5ba54aa10bb8936f3575e3b97916d299783cf858.zip
sdl_sound: add optional dependencies
Add the optional dependencies we have in BR (flac/speex/vorbis). Signed-off-by: Peter Korsgaard <jacmet@sunsite.dk>
Diffstat (limited to 'package/sdl_sound')
-rw-r--r--package/sdl_sound/sdl_sound.mk13
1 files changed, 13 insertions, 0 deletions
diff --git a/package/sdl_sound/sdl_sound.mk b/package/sdl_sound/sdl_sound.mk
index 5058551b0..3a6b7e742 100644
--- a/package/sdl_sound/sdl_sound.mk
+++ b/package/sdl_sound/sdl_sound.mk
@@ -15,6 +15,19 @@ ifneq ($(BR2_ENABLE_LOCALE),y)
SDL_SOUND_DEPENDENCIES += libiconv
endif
+# optional dependencies
+ifeq ($(BR2_PACKAGE_FLAC),y)
+SDL_SOUND_DEPENDENCIES += flac # is only used if ogg is also enabled
+endif
+
+ifeq ($(BR2_PACKAGE_LIBVORBIS),y)
+SDL_SOUND_DEPENDENCIES += libvorbis
+endif
+
+ifeq ($(BR2_PACKAGE_SPEEX),y)
+SDL_SOUND_DEPENDENCIES += speex
+endif
+
SDL_SOUND_CONF_OPT:=--with-sdl-prefix=$(STAGING_DIR)/usr \
--with-sdl-exec-prefix=$(STAGING_DIR)/usr \
--disable-sdltest \