summaryrefslogtreecommitdiffstats
path: root/package/sdl_sound/sdl_sound.mk
diff options
context:
space:
mode:
Diffstat (limited to 'package/sdl_sound/sdl_sound.mk')
-rw-r--r--package/sdl_sound/sdl_sound.mk13
1 files changed, 13 insertions, 0 deletions
diff --git a/package/sdl_sound/sdl_sound.mk b/package/sdl_sound/sdl_sound.mk
index 5058551b0..3a6b7e742 100644
--- a/package/sdl_sound/sdl_sound.mk
+++ b/package/sdl_sound/sdl_sound.mk
@@ -15,6 +15,19 @@ ifneq ($(BR2_ENABLE_LOCALE),y)
SDL_SOUND_DEPENDENCIES += libiconv
endif
+# optional dependencies
+ifeq ($(BR2_PACKAGE_FLAC),y)
+SDL_SOUND_DEPENDENCIES += flac # is only used if ogg is also enabled
+endif
+
+ifeq ($(BR2_PACKAGE_LIBVORBIS),y)
+SDL_SOUND_DEPENDENCIES += libvorbis
+endif
+
+ifeq ($(BR2_PACKAGE_SPEEX),y)
+SDL_SOUND_DEPENDENCIES += speex
+endif
+
SDL_SOUND_CONF_OPT:=--with-sdl-prefix=$(STAGING_DIR)/usr \
--with-sdl-exec-prefix=$(STAGING_DIR)/usr \
--disable-sdltest \