summaryrefslogtreecommitdiffstats
path: root/package/sdl/sdl.mk
diff options
context:
space:
mode:
authorPeter Korsgaard <jacmet@sunsite.dk>2013-04-28 22:32:39 +0200
committerPeter Korsgaard <jacmet@sunsite.dk>2013-04-28 22:32:39 +0200
commit1655f3c5b735b3dad75df1665b47d309fdf3afcb (patch)
tree30870b1aa2122dc1d83d6fab8bf36bbcf3937729 /package/sdl/sdl.mk
parent37c6e51a15e8f932cfe23b60d2d37c47213fde83 (diff)
downloadbuildroot-novena-1655f3c5b735b3dad75df1665b47d309fdf3afcb.tar.gz
buildroot-novena-1655f3c5b735b3dad75df1665b47d309fdf3afcb.zip
sdl: fix directfb configure check
The configure script nicely supports a preconfigured directfb-config (using ac_cv_path_DIRECTFBCONFIG), except for when it checks the directfb version where it simply uses whatever directfb-config is in the path, breaking the build when this isn't available / recent enough. Fix is to use the correct one instead. As SDL doesn't autoreconf cleanly, also patch the generated configure script. Finally move the ac_cv_path_DIRECTFBCONFIG setting under the directfb conditional as it is only needed there. Signed-off-by: Peter Korsgaard <jacmet@sunsite.dk>
Diffstat (limited to 'package/sdl/sdl.mk')
-rw-r--r--package/sdl/sdl.mk2
1 files changed, 1 insertions, 1 deletions
diff --git a/package/sdl/sdl.mk b/package/sdl/sdl.mk
index fb47c4d19..59576fbc4 100644
--- a/package/sdl/sdl.mk
+++ b/package/sdl/sdl.mk
@@ -8,7 +8,6 @@ SDL_VERSION = 1.2.15
SDL_SOURCE = SDL-$(SDL_VERSION).tar.gz
SDL_SITE = http://www.libsdl.org/release
SDL_INSTALL_STAGING = YES
-SDL_CONF_ENV = ac_cv_path_DIRECTFBCONFIG=$(STAGING_DIR)/usr/bin/directfb-config
ifeq ($(BR2_PACKAGE_SDL_FBCON),y)
SDL_CONF_OPT+=--enable-video-fbcon=yes
@@ -19,6 +18,7 @@ endif
ifeq ($(BR2_PACKAGE_SDL_DIRECTFB),y)
SDL_DEPENDENCIES += directfb
SDL_CONF_OPT+=--enable-video-directfb=yes
+SDL_CONF_ENV = ac_cv_path_DIRECTFBCONFIG=$(STAGING_DIR)/usr/bin/directfb-config
else
SDL_CONF_OPT=--enable-video-directfb=no
endif