summaryrefslogtreecommitdiffstats
path: root/package/sdl
diff options
context:
space:
mode:
authorPeter Korsgaard <jacmet@sunsite.dk>2013-04-28 22:32:39 +0200
committerPeter Korsgaard <jacmet@sunsite.dk>2013-04-28 22:32:39 +0200
commit1655f3c5b735b3dad75df1665b47d309fdf3afcb (patch)
tree30870b1aa2122dc1d83d6fab8bf36bbcf3937729 /package/sdl
parent37c6e51a15e8f932cfe23b60d2d37c47213fde83 (diff)
downloadbuildroot-novena-1655f3c5b735b3dad75df1665b47d309fdf3afcb.tar.gz
buildroot-novena-1655f3c5b735b3dad75df1665b47d309fdf3afcb.zip
sdl: fix directfb configure check
The configure script nicely supports a preconfigured directfb-config (using ac_cv_path_DIRECTFBCONFIG), except for when it checks the directfb version where it simply uses whatever directfb-config is in the path, breaking the build when this isn't available / recent enough. Fix is to use the correct one instead. As SDL doesn't autoreconf cleanly, also patch the generated configure script. Finally move the ac_cv_path_DIRECTFBCONFIG setting under the directfb conditional as it is only needed there. Signed-off-by: Peter Korsgaard <jacmet@sunsite.dk>
Diffstat (limited to 'package/sdl')
-rw-r--r--package/sdl/sdl-use-correct-directfb-config.patch40
-rw-r--r--package/sdl/sdl.mk2
2 files changed, 41 insertions, 1 deletions
diff --git a/package/sdl/sdl-use-correct-directfb-config.patch b/package/sdl/sdl-use-correct-directfb-config.patch
new file mode 100644
index 000000000..225079083
--- /dev/null
+++ b/package/sdl/sdl-use-correct-directfb-config.patch
@@ -0,0 +1,40 @@
+[PATCH] configure.in: use correct directfb-config in version check
+
+The configure script has just checked for the correct directfb-config
+script, so also use it for the version check instead of whatever
+might be in the path.
+
+Also patch the generated configure, as it doesn't cleanly autoreconf.
+
+Signed-off-by: Peter Korsgaard <jacmet@sunsite.dk>
+---
+ configure | 2 +-
+ configure.in | 2 +-
+ 2 files changed, 2 insertions(+), 2 deletions(-)
+
+Index: SDL-1.2.15/configure.in
+===================================================================
+--- SDL-1.2.15.orig/configure.in
++++ SDL-1.2.15/configure.in
+@@ -1276,7 +1276,7 @@
+ else
+ set -- `echo $DIRECTFB_REQUIRED_VERSION | sed 's/\./ /g'`
+ NEED_VERSION=`expr $1 \* 10000 + $2 \* 100 + $3`
+- set -- `directfb-config --version | sed 's/\./ /g'`
++ set -- `$DIRECTFBCONFIG --version | sed 's/\./ /g'`
+ HAVE_VERSION=`expr $1 \* 10000 + $2 \* 100 + $3`
+ if test $HAVE_VERSION -ge $NEED_VERSION; then
+ DIRECTFB_CFLAGS=`$DIRECTFBCONFIG --cflags`
+Index: SDL-1.2.15/configure
+===================================================================
+--- SDL-1.2.15.orig/configure
++++ SDL-1.2.15/configure
+@@ -24958,7 +24958,7 @@
+ else
+ set -- `echo $DIRECTFB_REQUIRED_VERSION | sed 's/\./ /g'`
+ NEED_VERSION=`expr $1 \* 10000 + $2 \* 100 + $3`
+- set -- `directfb-config --version | sed 's/\./ /g'`
++ set -- `$DIRECTFBCONFIG --version | sed 's/\./ /g'`
+ HAVE_VERSION=`expr $1 \* 10000 + $2 \* 100 + $3`
+ if test $HAVE_VERSION -ge $NEED_VERSION; then
+ DIRECTFB_CFLAGS=`$DIRECTFBCONFIG --cflags`
diff --git a/package/sdl/sdl.mk b/package/sdl/sdl.mk
index fb47c4d19..59576fbc4 100644
--- a/package/sdl/sdl.mk
+++ b/package/sdl/sdl.mk
@@ -8,7 +8,6 @@ SDL_VERSION = 1.2.15
SDL_SOURCE = SDL-$(SDL_VERSION).tar.gz
SDL_SITE = http://www.libsdl.org/release
SDL_INSTALL_STAGING = YES
-SDL_CONF_ENV = ac_cv_path_DIRECTFBCONFIG=$(STAGING_DIR)/usr/bin/directfb-config
ifeq ($(BR2_PACKAGE_SDL_FBCON),y)
SDL_CONF_OPT+=--enable-video-fbcon=yes
@@ -19,6 +18,7 @@ endif
ifeq ($(BR2_PACKAGE_SDL_DIRECTFB),y)
SDL_DEPENDENCIES += directfb
SDL_CONF_OPT+=--enable-video-directfb=yes
+SDL_CONF_ENV = ac_cv_path_DIRECTFBCONFIG=$(STAGING_DIR)/usr/bin/directfb-config
else
SDL_CONF_OPT=--enable-video-directfb=no
endif