summaryrefslogtreecommitdiffstats
path: root/package/qt
diff options
context:
space:
mode:
authorDaniel Mack <zonque@gmail.com>2011-05-31 18:16:34 +0200
committerPeter Korsgaard <jacmet@sunsite.dk>2011-06-20 11:50:43 +0200
commit377b2785c136e7439ac4f4a6e4509bc5c9fe3015 (patch)
tree0cb01024274a7a156ee196202655796fca843067 /package/qt
parent85aed3e325e953025426fdde0447359ab7a4c8a6 (diff)
downloadbuildroot-novena-377b2785c136e7439ac4f4a6e4509bc5c9fe3015.tar.gz
buildroot-novena-377b2785c136e7439ac4f4a6e4509bc5c9fe3015.zip
Qt: add config option to build libQtDeclarative module
Signed-off-by: Daniel Mack <zonque@gmail.com> Acked-by: Daniel Nyström <daniel.nystrom@timeterminal.se> Signed-off-by: Peter Korsgaard <jacmet@sunsite.dk>
Diffstat (limited to 'package/qt')
-rw-r--r--package/qt/Config.in7
-rw-r--r--package/qt/qt.mk9
2 files changed, 16 insertions, 0 deletions
diff --git a/package/qt/Config.in b/package/qt/Config.in
index 4a3945c82..214f14090 100644
--- a/package/qt/Config.in
+++ b/package/qt/Config.in
@@ -378,4 +378,11 @@ config BR2_PACKAGE_QT_SCRIPTTOOLS
Build the Qt Script Tools module.
if unsure, say n.
+config BR2_PACKAGE_QT_DECLARATIVE
+ bool "Declarative module"
+ depends on BR2_PACKAGE_QT_GUI_MODULE
+ help
+ Build the Qt Declarative Module for qml support
+ if unsure, say n.
+
endif # BR2_PACKAGE_QT
diff --git a/package/qt/qt.mk b/package/qt/qt.mk
index 8bcbd3fef..e8b7a4964 100644
--- a/package/qt/qt.mk
+++ b/package/qt/qt.mk
@@ -398,6 +398,12 @@ else
QT_CONFIGURE_OPTS += -no-stl
endif
+ifeq ($(BR2_PACKAGE_QT_DECLARATIVE),y)
+QT_CONFIGURE_OPTS += -declarative
+else
+QT_CONFIGURE_OPTS += -no-declarative
+endif
+
# ccache and precompiled headers don't play well together
ifeq ($(BR2_CCACHE),y)
QT_CONFIGURE_OPTS += -no-pch
@@ -535,6 +541,9 @@ endif
ifeq ($(BR2_PACKAGE_QT_SCRIPTTOOLS),y)
QT_INSTALL_LIBS += QtScriptTools
endif
+ifeq ($(BR2_PACKAGE_QT_DECLARATIVE),y)
+QT_INSTALL_LIBS += QtDeclarative
+endif
ifeq ($(BR2_PACKAGE_QT_QT3SUPPORT),y)
QT_INSTALL_LIBS += Qt3Support
endif