summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--package/qt/Config.in7
-rw-r--r--package/qt/qt.mk9
2 files changed, 16 insertions, 0 deletions
diff --git a/package/qt/Config.in b/package/qt/Config.in
index 4a3945c82..214f14090 100644
--- a/package/qt/Config.in
+++ b/package/qt/Config.in
@@ -378,4 +378,11 @@ config BR2_PACKAGE_QT_SCRIPTTOOLS
Build the Qt Script Tools module.
if unsure, say n.
+config BR2_PACKAGE_QT_DECLARATIVE
+ bool "Declarative module"
+ depends on BR2_PACKAGE_QT_GUI_MODULE
+ help
+ Build the Qt Declarative Module for qml support
+ if unsure, say n.
+
endif # BR2_PACKAGE_QT
diff --git a/package/qt/qt.mk b/package/qt/qt.mk
index 8bcbd3fef..e8b7a4964 100644
--- a/package/qt/qt.mk
+++ b/package/qt/qt.mk
@@ -398,6 +398,12 @@ else
QT_CONFIGURE_OPTS += -no-stl
endif
+ifeq ($(BR2_PACKAGE_QT_DECLARATIVE),y)
+QT_CONFIGURE_OPTS += -declarative
+else
+QT_CONFIGURE_OPTS += -no-declarative
+endif
+
# ccache and precompiled headers don't play well together
ifeq ($(BR2_CCACHE),y)
QT_CONFIGURE_OPTS += -no-pch
@@ -535,6 +541,9 @@ endif
ifeq ($(BR2_PACKAGE_QT_SCRIPTTOOLS),y)
QT_INSTALL_LIBS += QtScriptTools
endif
+ifeq ($(BR2_PACKAGE_QT_DECLARATIVE),y)
+QT_INSTALL_LIBS += QtDeclarative
+endif
ifeq ($(BR2_PACKAGE_QT_QT3SUPPORT),y)
QT_INSTALL_LIBS += Qt3Support
endif