summaryrefslogtreecommitdiffstats
path: root/package/qt5
diff options
context:
space:
mode:
authorThomas Petazzoni <thomas.petazzoni@free-electrons.com>2013-03-19 09:29:37 +0000
committerPeter Korsgaard <jacmet@sunsite.dk>2013-03-19 22:10:24 +0100
commitf5b9811a837ca562c94ffc148e0679c974813fdf (patch)
tree574c88ba89b3639377439f39471d6ec4b29b6cb5 /package/qt5
parent9e9a3e6b0055938adf266a17fee9b0f75d750b9d (diff)
downloadbuildroot-novena-f5b9811a837ca562c94ffc148e0679c974813fdf.tar.gz
buildroot-novena-f5b9811a837ca562c94ffc148e0679c974813fdf.zip
qt5base: add D-Bus support
Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com> Signed-off-by: Peter Korsgaard <jacmet@sunsite.dk>
Diffstat (limited to 'package/qt5')
-rw-r--r--package/qt5/qt5base/Config.in8
-rw-r--r--package/qt5/qt5base/qt5base.mk6
2 files changed, 13 insertions, 1 deletions
diff --git a/package/qt5/qt5base/Config.in b/package/qt5/qt5base/Config.in
index 8b0291b54..d313db918 100644
--- a/package/qt5/qt5base/Config.in
+++ b/package/qt5/qt5base/Config.in
@@ -132,4 +132,12 @@ config BR2_PACKAGE_QT5BASE_PNG
endif
+config BR2_PACKAGE_QT5BASE_DBUS
+ bool "DBus module"
+ select BR2_PACKAGE_DBUS
+ depends on BR2_TOOLCHAIN_HAS_THREADS
+ depends on BR2_USE_MMU
+ help
+ This option enables the D-Bus module.
+
endif
diff --git a/package/qt5/qt5base/qt5base.mk b/package/qt5/qt5base/qt5base.mk
index 65fe451e0..62f0b9a9d 100644
--- a/package/qt5/qt5base/qt5base.mk
+++ b/package/qt5/qt5base/qt5base.mk
@@ -27,7 +27,6 @@ QT5BASE_CONFIGURE_OPTS += \
-no-libudev \
-no-iconv \
-no-icu \
- -no-dbus \
-no-gstreamer \
-no-gtkstyle \
-system-zlib \
@@ -93,6 +92,9 @@ QT5BASE_DEPENDENCIES += $(if $(BR2_PACKAGE_QT5BASE_JPEG),jpeg)
QT5BASE_CONFIGURE_OPTS += $(if $(BR2_PACKAGE_QT5BASE_PNG),-system-libpng,-no-libpng)
QT5BASE_DEPENDENCIES += $(if $(BR2_PACKAGE_QT5BASE_PNG),libpng)
+QT5BASE_CONFIGURE_OPTS += $(if $(BR2_PACKAGE_QT5BASE_DBUS),-dbus,-no-dbus)
+QT5BASE_DEPENDENCIES += $(if $(BR2_PACKAGE_QT5BASE_DBUS),dbus)
+
# Build the list of libraries to be installed on the target
QT5BASE_INSTALL_LIBS_y += Qt5Core
QT5BASE_INSTALL_LIBS_$(BR2_PACKAGE_QT5BASE_NETWORK) += Qt5Network
@@ -105,6 +107,8 @@ QT5BASE_INSTALL_LIBS_$(BR2_PACKAGE_QT5BASE_GUI) += Qt5Gui
QT5BASE_INSTALL_LIBS_$(BR2_PACKAGE_QT5BASE_WIDGETS) += Qt5Widgets
QT5BASE_INSTALL_LIBS_$(BR2_PACKAGE_QT5BASE_PRINTSUPPORT) += Qt5PrintSupport
+QT5BASE_INSTALL_LIBS_$(BR2_PACKAGE_QT5BASE_DBUS) += Qt5DBus
+
# Ideally, we could use -device-option to substitute variable values
# in our linux-buildroot-g++/qmake.config, but this mechanism doesn't
# nicely support variable values that contain spaces. So we use the