summaryrefslogtreecommitdiffstats
path: root/package/qt5
diff options
context:
space:
mode:
authorThomas Petazzoni <thomas.petazzoni@free-electrons.com>2013-03-19 09:29:36 +0000
committerPeter Korsgaard <jacmet@sunsite.dk>2013-03-19 22:08:29 +0100
commit9e9a3e6b0055938adf266a17fee9b0f75d750b9d (patch)
tree9e0e9c88e7f06b2c2a9ce61d37202e4e99ab365e /package/qt5
parentd2b86608ac37b5bce78d0214ffee0a93f58da0f0 (diff)
downloadbuildroot-novena-9e9a3e6b0055938adf266a17fee9b0f75d750b9d.tar.gz
buildroot-novena-9e9a3e6b0055938adf266a17fee9b0f75d750b9d.zip
qt5base: add support for fontconfig, png, jpeg, gif
Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com> Signed-off-by: Peter Korsgaard <jacmet@sunsite.dk>
Diffstat (limited to 'package/qt5')
-rw-r--r--package/qt5/qt5base/Config.in26
-rw-r--r--package/qt5/qt5base/qt5base.mk12
2 files changed, 34 insertions, 4 deletions
diff --git a/package/qt5/qt5base/Config.in b/package/qt5/qt5base/Config.in
index 0af5df642..8b0291b54 100644
--- a/package/qt5/qt5base/Config.in
+++ b/package/qt5/qt5base/Config.in
@@ -104,6 +104,32 @@ config BR2_PACKAGE_QT5BASE_PRINTSUPPORT
help
This option enables the Qt5PrintSupport
+config BR2_PACKAGE_QT5BASE_FONTCONFIG
+ bool "fontconfig support"
+ select BR2_PACKAGE_FONTCONFIG
+ help
+ This option enables Fontconfig and Freetype support using
+ the system fontconfig and freetype2 libraries.
+
+config BR2_PACKAGE_QT5BASE_GIF
+ bool "GIF support"
+ help
+ This compiles and installs the plugin for GIF reading support.
+
+config BR2_PACKAGE_QT5BASE_JPEG
+ bool "JPEG support"
+ select BR2_PACKAGE_JPEG
+ help
+ This option enables JPEG support using the system libjpeg
+ library.
+
+config BR2_PACKAGE_QT5BASE_PNG
+ bool "PNG support"
+ select BR2_PACKAGE_LIBPNG
+ help
+ This option enables PNG support using the system libpng
+ library.
+
endif
endif
diff --git a/package/qt5/qt5base/qt5base.mk b/package/qt5/qt5base/qt5base.mk
index 700bc67b8..65fe451e0 100644
--- a/package/qt5/qt5base/qt5base.mk
+++ b/package/qt5/qt5base/qt5base.mk
@@ -26,10 +26,6 @@ QT5BASE_CONFIGURE_OPTS += \
-no-nis \
-no-libudev \
-no-iconv \
- -no-fontconfig \
- -no-gif \
- -no-libpng \
- -no-libjpeg \
-no-icu \
-no-dbus \
-no-gstreamer \
@@ -89,6 +85,14 @@ endif
QT5BASE_CONFIGURE_OPTS += $(if $(BR2_PACKAGE_OPENSSL),-openssl,-no-openssl)
QT5BASE_DEPENDENCIES += $(if $(BR2_PACKAGE_OPENSSL),openssl)
+QT5BASE_CONFIGURE_OPTS += $(if $(BR2_PACKAGE_QT5BASE_FONTCONFIG),-fontconfig,-no-fontconfig)
+QT5BASE_DEPENDENCIES += $(if $(BR2_PACKAGE_QT5BASE_FONTCONFIG),fontconfig)
+QT5BASE_CONFIGURE_OPTS += $(if $(BR2_PACKAGE_QT5BASE_GIF),,-no-gif)
+QT5BASE_CONFIGURE_OPTS += $(if $(BR2_PACKAGE_QT5BASE_JPEG),-system-libjpeg,-no-libjpeg)
+QT5BASE_DEPENDENCIES += $(if $(BR2_PACKAGE_QT5BASE_JPEG),jpeg)
+QT5BASE_CONFIGURE_OPTS += $(if $(BR2_PACKAGE_QT5BASE_PNG),-system-libpng,-no-libpng)
+QT5BASE_DEPENDENCIES += $(if $(BR2_PACKAGE_QT5BASE_PNG),libpng)
+
# Build the list of libraries to be installed on the target
QT5BASE_INSTALL_LIBS_y += Qt5Core
QT5BASE_INSTALL_LIBS_$(BR2_PACKAGE_QT5BASE_NETWORK) += Qt5Network