summaryrefslogtreecommitdiffstats
path: root/package/qt5
diff options
context:
space:
mode:
authorThomas Petazzoni <thomas.petazzoni@free-electrons.com>2013-03-07 10:18:36 +0000
committerPeter Korsgaard <jacmet@sunsite.dk>2013-03-10 22:36:32 +0100
commitca249584cb64bdffe968db0d0addde89350e9e6c (patch)
tree7fa88c50e1bd7c8f4f8f325e20c0d74302306ba7 /package/qt5
parentac26e65cc3591c1185a7d13309d3d0744acb2c3b (diff)
downloadbuildroot-novena-ca249584cb64bdffe968db0d0addde89350e9e6c.tar.gz
buildroot-novena-ca249584cb64bdffe968db0d0addde89350e9e6c.zip
qt5: base infrastructure
Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com> Signed-off-by: Peter Korsgaard <jacmet@sunsite.dk>
Diffstat (limited to 'package/qt5')
-rw-r--r--package/qt5/Config.in18
-rw-r--r--package/qt5/qt5.mk1
2 files changed, 19 insertions, 0 deletions
diff --git a/package/qt5/Config.in b/package/qt5/Config.in
new file mode 100644
index 000000000..0acb89e79
--- /dev/null
+++ b/package/qt5/Config.in
@@ -0,0 +1,18 @@
+comment "Qt5 needs a toolchain with WCHAR, IPv6, thread and C++ support"
+ depends on !BR2_INSTALL_LIBSTDCPP || !BR2_USE_WCHAR || !BR2_INET_IPV6 || !BR2_TOOLCHAIN_HAS_THREADS
+
+menuconfig BR2_PACKAGE_QT5
+ bool "Qt5"
+ depends on BR2_INSTALL_LIBSTDCPP
+ depends on BR2_USE_WCHAR
+ depends on BR2_INET_IPV6
+ depends on BR2_TOOLCHAIN_HAS_THREADS
+ help
+ This option enables the Qt5 framework. Sub-options allow to
+ select which modules should be built.
+
+ http://qt-project.org
+
+if BR2_PACKAGE_QT5
+
+endif
diff --git a/package/qt5/qt5.mk b/package/qt5/qt5.mk
new file mode 100644
index 000000000..8b1a7ed3e
--- /dev/null
+++ b/package/qt5/qt5.mk
@@ -0,0 +1 @@
+include package/qt5/*/*.mk