summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--package/qt5/Config.in18
-rw-r--r--package/qt5/qt5.mk1
2 files changed, 19 insertions, 0 deletions
diff --git a/package/qt5/Config.in b/package/qt5/Config.in
new file mode 100644
index 000000000..0acb89e79
--- /dev/null
+++ b/package/qt5/Config.in
@@ -0,0 +1,18 @@
+comment "Qt5 needs a toolchain with WCHAR, IPv6, thread and C++ support"
+ depends on !BR2_INSTALL_LIBSTDCPP || !BR2_USE_WCHAR || !BR2_INET_IPV6 || !BR2_TOOLCHAIN_HAS_THREADS
+
+menuconfig BR2_PACKAGE_QT5
+ bool "Qt5"
+ depends on BR2_INSTALL_LIBSTDCPP
+ depends on BR2_USE_WCHAR
+ depends on BR2_INET_IPV6
+ depends on BR2_TOOLCHAIN_HAS_THREADS
+ help
+ This option enables the Qt5 framework. Sub-options allow to
+ select which modules should be built.
+
+ http://qt-project.org
+
+if BR2_PACKAGE_QT5
+
+endif
diff --git a/package/qt5/qt5.mk b/package/qt5/qt5.mk
new file mode 100644
index 000000000..8b1a7ed3e
--- /dev/null
+++ b/package/qt5/qt5.mk
@@ -0,0 +1 @@
+include package/qt5/*/*.mk