summaryrefslogtreecommitdiffstats
path: root/package/qt5
diff options
context:
space:
mode:
authorThomas Petazzoni <thomas.petazzoni@free-electrons.com>2013-03-07 10:18:37 +0000
committerPeter Korsgaard <jacmet@sunsite.dk>2013-03-10 22:36:59 +0100
commit1737b5648c9f778149eb7da5897b66a9577d22c4 (patch)
tree2abf5a0c09d13b4f02ac45a6942ed103e4b27abf /package/qt5
parentca249584cb64bdffe968db0d0addde89350e9e6c (diff)
downloadbuildroot-novena-1737b5648c9f778149eb7da5897b66a9577d22c4.tar.gz
buildroot-novena-1737b5648c9f778149eb7da5897b66a9577d22c4.zip
qt5: add macro to fixup Qt5 .la and .prl files
Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com> Signed-off-by: Peter Korsgaard <jacmet@sunsite.dk>
Diffstat (limited to 'package/qt5')
-rw-r--r--package/qt5/qt5.mk10
1 files changed, 10 insertions, 0 deletions
diff --git a/package/qt5/qt5.mk b/package/qt5/qt5.mk
index 8b1a7ed3e..f22050876 100644
--- a/package/qt5/qt5.mk
+++ b/package/qt5/qt5.mk
@@ -1 +1,11 @@
include package/qt5/*/*.mk
+
+define QT5_LA_PRL_FILES_FIXUP
+ for i in $$(find $(STAGING_DIR)/usr/lib* -name "libQt5*.la"); do \
+ $(SED) "s:\(['= ]\)/usr:\\1$(STAGING_DIR)/usr:g" $$i; \
+ $(SED) "/^dependency_libs=/s%-L/usr/lib %%g" $$i ; \
+ done
+ for i in $$(find $(STAGING_DIR)/usr/lib* -name "libQt5*.prl"); do \
+ $(SED) "s%-L/usr/lib%%" $$i; \
+ done
+endef