summaryrefslogtreecommitdiffstats
path: root/package/procps/procps.mk
diff options
context:
space:
mode:
author"Steven J. Hill" <sjhill@realitydiluted.com>2007-07-06 04:26:32 +0000
committer"Steven J. Hill" <sjhill@realitydiluted.com>2007-07-06 04:26:32 +0000
commit9a4ca08e5ffee842d0ede78c4ce9f745f0ca42b6 (patch)
tree3f0ef80e7c44f59eae59c0fdfb9b56882d454112 /package/procps/procps.mk
parent9fba54740004859fd7e0936cda64d01c2b48633b (diff)
downloadbuildroot-novena-9a4ca08e5ffee842d0ede78c4ce9f745f0ca42b6.tar.gz
buildroot-novena-9a4ca08e5ffee842d0ede78c4ce9f745f0ca42b6.zip
Remove usage of TARGET_LDFLAGS all together. Both TARGET_CFLAGS and TARGET_LDFLAGS are passed with the compilers and linker respectively so that we can pass CFLAGS and LDFLAGS on a per-package basis which was not possible previously and a number of packages failed to build. TARGET_CFLAGS usage in package makefiles will be removed next.
Diffstat (limited to 'package/procps/procps.mk')
-rw-r--r--package/procps/procps.mk5
1 files changed, 1 insertions, 4 deletions
diff --git a/package/procps/procps.mk b/package/procps/procps.mk
index ff0aac6e5..3cab79d82 100644
--- a/package/procps/procps.mk
+++ b/package/procps/procps.mk
@@ -16,13 +16,10 @@ $(DL_DIR)/$(PROCPS_SOURCE):
$(PROCPS_DIR)/.source: $(DL_DIR)/$(PROCPS_SOURCE)
$(ZCAT) $(DL_DIR)/$(PROCPS_SOURCE) | tar -C $(BUILD_DIR) $(TAR_OPTIONS) -
toolchain/patch-kernel.sh $(PROCPS_DIR) package/procps/ procps\*.patch
- $(SED) '/^CFLAGS/s:-O2:$(TARGET_CFLAGS):' $(PROCPS_DIR)/Makefile
- $(SED) '/^LDFLAGS/s:$$:$(TARGET_LDFLAGS):' $(PROCPS_DIR)/Makefile
touch $(PROCPS_DIR)/.source
$(PROCPS_DIR)/$(PROCPS_BINARY): $(PROCPS_DIR)/.source
- $(TARGET_CONFIGURE_OPTS) $(MAKE) CPPFLAGS=-I$(STAGING_DIR)/include \
- CC=$(TARGET_CC) -C $(PROCPS_DIR)
+ $(TARGET_CONFIGURE_OPTS) $(MAKE) -C $(PROCPS_DIR)
$(TARGET_DIR)/$(PROCPS_TARGET_BINARY): $(PROCPS_DIR)/$(PROCPS_BINARY)
$(TARGET_CONFIGURE_OPTS) $(MAKE) DESTDIR=$(TARGET_DIR) \