summaryrefslogtreecommitdiffstats
path: root/package/procps
diff options
context:
space:
mode:
author"Steven J. Hill" <sjhill@realitydiluted.com>2007-07-06 04:26:32 +0000
committer"Steven J. Hill" <sjhill@realitydiluted.com>2007-07-06 04:26:32 +0000
commit9a4ca08e5ffee842d0ede78c4ce9f745f0ca42b6 (patch)
tree3f0ef80e7c44f59eae59c0fdfb9b56882d454112 /package/procps
parent9fba54740004859fd7e0936cda64d01c2b48633b (diff)
downloadbuildroot-novena-9a4ca08e5ffee842d0ede78c4ce9f745f0ca42b6.tar.gz
buildroot-novena-9a4ca08e5ffee842d0ede78c4ce9f745f0ca42b6.zip
Remove usage of TARGET_LDFLAGS all together. Both TARGET_CFLAGS and TARGET_LDFLAGS are passed with the compilers and linker respectively so that we can pass CFLAGS and LDFLAGS on a per-package basis which was not possible previously and a number of packages failed to build. TARGET_CFLAGS usage in package makefiles will be removed next.
Diffstat (limited to 'package/procps')
-rw-r--r--package/procps/procps-remove-flags.patch26
-rw-r--r--package/procps/procps.mk5
2 files changed, 27 insertions, 4 deletions
diff --git a/package/procps/procps-remove-flags.patch b/package/procps/procps-remove-flags.patch
new file mode 100644
index 000000000..cb4dc56d5
--- /dev/null
+++ b/package/procps/procps-remove-flags.patch
@@ -0,0 +1,26 @@
+diff -u procps-3.2.5/Makefile procps-3.2.5-patched/Makefile
+--- procps-3.2.5/Makefile 2005-01-25 22:55:26.000000000 -0600
++++ procps-3.2.5-patched/Makefile 2007-07-05 23:09:24.251423681 -0500
+@@ -70,9 +70,7 @@
+ CURSES := -lncurses
+
+ # Preprocessor flags.
+-PKG_CPPFLAGS := -D_GNU_SOURCE -I proc
+-CPPFLAGS := -I/usr/include/ncurses
+-ALL_CPPFLAGS := $(PKG_CPPFLAGS) $(CPPFLAGS)
++ALL_CPPFLAGS := -D_GNU_SOURCE -I proc
+
+ # Left out -Wconversion due to noise in glibc headers.
+ # Left out -Wunreachable-code and -Wdisabled-optimization
+@@ -91,11 +89,9 @@
+ -Wstrict-prototypes -Wmissing-prototypes
+ # Note that some stuff below is conditional on CFLAGS containing
+ # an option that starts with "-g". (-g, -g2, -g3, -ggdb, etc.)
+-CFLAGS := -O2 -s
+ ALL_CFLAGS := $(PKG_CFLAGS) $(CFLAGS)
+
+ PKG_LDFLAGS := -Wl,-warn-common
+-LDFLAGS :=
+ ALL_LDFLAGS := $(PKG_LDFLAGS) $(LDFLAGS)
+
+ ############ Add some extra flags if gcc allows
diff --git a/package/procps/procps.mk b/package/procps/procps.mk
index ff0aac6e5..3cab79d82 100644
--- a/package/procps/procps.mk
+++ b/package/procps/procps.mk
@@ -16,13 +16,10 @@ $(DL_DIR)/$(PROCPS_SOURCE):
$(PROCPS_DIR)/.source: $(DL_DIR)/$(PROCPS_SOURCE)
$(ZCAT) $(DL_DIR)/$(PROCPS_SOURCE) | tar -C $(BUILD_DIR) $(TAR_OPTIONS) -
toolchain/patch-kernel.sh $(PROCPS_DIR) package/procps/ procps\*.patch
- $(SED) '/^CFLAGS/s:-O2:$(TARGET_CFLAGS):' $(PROCPS_DIR)/Makefile
- $(SED) '/^LDFLAGS/s:$$:$(TARGET_LDFLAGS):' $(PROCPS_DIR)/Makefile
touch $(PROCPS_DIR)/.source
$(PROCPS_DIR)/$(PROCPS_BINARY): $(PROCPS_DIR)/.source
- $(TARGET_CONFIGURE_OPTS) $(MAKE) CPPFLAGS=-I$(STAGING_DIR)/include \
- CC=$(TARGET_CC) -C $(PROCPS_DIR)
+ $(TARGET_CONFIGURE_OPTS) $(MAKE) -C $(PROCPS_DIR)
$(TARGET_DIR)/$(PROCPS_TARGET_BINARY): $(PROCPS_DIR)/$(PROCPS_BINARY)
$(TARGET_CONFIGURE_OPTS) $(MAKE) DESTDIR=$(TARGET_DIR) \