summaryrefslogtreecommitdiffstats
path: root/package/php
diff options
context:
space:
mode:
authorThomas Petazzoni <thomas.petazzoni@free-electrons.com>2012-11-17 12:24:06 +0000
committerPeter Korsgaard <jacmet@sunsite.dk>2012-11-17 23:49:16 +0100
commit5995d68f953aa0066eeaa245e2db52cc147de0d5 (patch)
tree5f506f096b93c19803540cd88bb48c6964b9d86f /package/php
parent7603f9d38af9d950686319d0ded621e82f4f1694 (diff)
downloadbuildroot-novena-5995d68f953aa0066eeaa245e2db52cc147de0d5.tar.gz
buildroot-novena-5995d68f953aa0066eeaa245e2db52cc147de0d5.zip
php: fix C++ link issue
The intl module is implemented in C++, but PHP fails to use g++ as the compiler for the final link. As a workaround, tell it to link with libstdc++. Fixes: http://autobuild.buildroot.org/results/13eefdf2121fa1aea7a844bbed8b6cbce3b45996/build-end.log Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com> Signed-off-by: Peter Korsgaard <jacmet@sunsite.dk>
Diffstat (limited to 'package/php')
-rw-r--r--package/php/php.mk4
1 files changed, 4 insertions, 0 deletions
diff --git a/package/php/php.mk b/package/php/php.mk
index 6ac9f2992..0dfb6db4b 100644
--- a/package/php/php.mk
+++ b/package/php/php.mk
@@ -102,6 +102,10 @@ endif
ifeq ($(BR2_PACKAGE_PHP_EXT_INTL),y)
PHP_CONF_OPT += --enable-intl --with-icu-dir=$(STAGING_DIR)/usr
PHP_DEPENDENCIES += icu
+ # The intl module is implemented in C++, but PHP fails to use
+ # g++ as the compiler for the final link. As a workaround,
+ # tell it to link libstdc++.
+ PHP_CONF_ENV += EXTRA_LIBS="-lstdc++"
endif
ifeq ($(BR2_PACKAGE_PHP_EXT_GMP),y)