summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--package/php/php.mk4
1 files changed, 4 insertions, 0 deletions
diff --git a/package/php/php.mk b/package/php/php.mk
index 6ac9f2992..0dfb6db4b 100644
--- a/package/php/php.mk
+++ b/package/php/php.mk
@@ -102,6 +102,10 @@ endif
ifeq ($(BR2_PACKAGE_PHP_EXT_INTL),y)
PHP_CONF_OPT += --enable-intl --with-icu-dir=$(STAGING_DIR)/usr
PHP_DEPENDENCIES += icu
+ # The intl module is implemented in C++, but PHP fails to use
+ # g++ as the compiler for the final link. As a workaround,
+ # tell it to link libstdc++.
+ PHP_CONF_ENV += EXTRA_LIBS="-lstdc++"
endif
ifeq ($(BR2_PACKAGE_PHP_EXT_GMP),y)