summaryrefslogtreecommitdiffstats
path: root/package/pciutils
diff options
context:
space:
mode:
authorPeter Korsgaard <jacmet@sunsite.dk>2012-12-17 09:27:30 +0100
committerPeter Korsgaard <jacmet@sunsite.dk>2012-12-17 09:27:30 +0100
commit8286d7113f481c2acbc9dc5ff62a364087700d51 (patch)
tree236127264486f96f3fdaaa551ffc3ca96477dc19 /package/pciutils
parent4f452a86b8523d90ffa7a94cb1d540e574ceb165 (diff)
downloadbuildroot-novena-8286d7113f481c2acbc9dc5ff62a364087700d51.tar.gz
buildroot-novena-8286d7113f481c2acbc9dc5ff62a364087700d51.zip
pciutils: work around race condition in make install with high BR2_JLEVEL
Fixes http://autobuild.buildroot.net/results/908d7368c8dc8e320fd33f3193039f5925adc352 make install and install-lib can race against eachother causing 'install' to fail. Work around it using MAKE1. Signed-off-by: Peter Korsgaard <jacmet@sunsite.dk>
Diffstat (limited to 'package/pciutils')
-rw-r--r--package/pciutils/pciutils.mk4
1 files changed, 2 insertions, 2 deletions
diff --git a/package/pciutils/pciutils.mk b/package/pciutils/pciutils.mk
index ba866a00a..6219711ff 100644
--- a/package/pciutils/pciutils.mk
+++ b/package/pciutils/pciutils.mk
@@ -48,12 +48,12 @@ endef
# Ditch install-lib if SHARED is an option in the future
define PCIUTILS_INSTALL_TARGET_CMDS
- $(MAKE) BUILDDIR=$(@D) -C $(@D) PREFIX=$(TARGET_DIR)/usr \
+ $(MAKE1) BUILDDIR=$(@D) -C $(@D) PREFIX=$(TARGET_DIR)/usr \
SHARED=$(PCIUTILS_SHARED) install install-lib
endef
define PCIUTILS_INSTALL_STAGING_CMDS
- $(MAKE) BUILDDIR=$(@D) -C $(@D) PREFIX=$(STAGING_DIR)/usr \
+ $(MAKE1) BUILDDIR=$(@D) -C $(@D) PREFIX=$(STAGING_DIR)/usr \
SHARED=$(PCIUTILS_SHARED) install install-lib
endef