summaryrefslogtreecommitdiffstats
path: root/package/pango
diff options
context:
space:
mode:
authorPeter Korsgaard <jacmet@sunsite.dk>2009-03-19 11:07:10 +0000
committerPeter Korsgaard <jacmet@sunsite.dk>2009-03-19 11:07:10 +0000
commit1d269dea1d25c8e0fc8cc16862dbe2e2fbd7f529 (patch)
treede73cc005e540f98fcd931358e66edf896b1b382 /package/pango
parente7b38c71ce55720f7709f0049f5bfc71ca0615ec (diff)
downloadbuildroot-novena-1d269dea1d25c8e0fc8cc16862dbe2e2fbd7f529.tar.gz
buildroot-novena-1d269dea1d25c8e0fc8cc16862dbe2e2fbd7f529.zip
pango: fix host build
pango likes to rerun it's configure script at make time, and it then fails to find the correct pkg-config files (it finds the ones ins STAGING_DIR) causing problems if they are not compatible. Fix it by setting PKG_CONFIG_PATH in it's make environment.
Diffstat (limited to 'package/pango')
-rw-r--r--package/pango/pango.mk2
1 files changed, 1 insertions, 1 deletions
diff --git a/package/pango/pango.mk b/package/pango/pango.mk
index b64d1a234..40c9d2a06 100644
--- a/package/pango/pango.mk
+++ b/package/pango/pango.mk
@@ -88,7 +88,7 @@ $(STAMP_DIR)/host_pango_configured: $(STAMP_DIR)/host_pango_unpacked $(STAMP_DIR
touch $@
$(STAMP_DIR)/host_pango_compiled: $(STAMP_DIR)/host_pango_configured
- $(HOST_MAKE_ENV) $(MAKE) -C $(PANGO_HOST_DIR)
+ $(HOST_MAKE_ENV) PKG_CONFIG_PATH="$(HOST_DIR)/usr/lib/pkgconfig$(PKG_CONFIG_PATH)" $(MAKE) -C $(PANGO_HOST_DIR)
touch $@
$(STAMP_DIR)/host_pango_installed: $(STAMP_DIR)/host_pango_compiled