summaryrefslogtreecommitdiffstats
path: root/package/pango
diff options
context:
space:
mode:
authorPeter Korsgaard <jacmet@sunsite.dk>2009-03-19 11:06:47 +0000
committerPeter Korsgaard <jacmet@sunsite.dk>2009-03-19 11:06:47 +0000
commite7b38c71ce55720f7709f0049f5bfc71ca0615ec (patch)
tree2ce70187ad1380f02c1777e7da3a48fb16d9f26a /package/pango
parentf58ff9a25f24576e032c65d762e5b8fdd2cf5c1c (diff)
downloadbuildroot-novena-e7b38c71ce55720f7709f0049f5bfc71ca0615ec.tar.gz
buildroot-novena-e7b38c71ce55720f7709f0049f5bfc71ca0615ec.zip
package: add STAMP_DIR and use for host builds
Move stamp (dependency) files outside the (version specific) source directories, so other packages can hardcode dependencies on them instead of having to use <PACKAGE>_VERSION variables. This is important as the variables in the make rules are evaluated when the rules is seen, which might be before the dependent makefile is parsed (and hence <PACKAGE>_VERSION variable is known, screwing up stuff. The downside of this is that the package isn't automatically rebuilt when the version changes (E.G. by a svn update) and you now also have to remove the stamp files next to $(BUILD_DIR)/<PACKAGE>-* to force a rebuild.
Diffstat (limited to 'package/pango')
-rw-r--r--package/pango/pango.mk31
1 files changed, 16 insertions, 15 deletions
diff --git a/package/pango/pango.mk b/package/pango/pango.mk
index 2db730e49..b64d1a234 100644
--- a/package/pango/pango.mk
+++ b/package/pango/pango.mk
@@ -66,40 +66,41 @@ $(PANGO_HOOK_POST_INSTALL):
PANGO_HOST_DIR:=$(BUILD_DIR)/pango-$(PANGO_VERSION)-host
PANGO_HOST_BINARY:=$(HOST_DIR)/usr/bin/pango-querymodules
-$(PANGO_HOST_DIR)/.unpacked: $(DL_DIR)/$(PANGO_SOURCE)
- mkdir -p $(@D)
+$(STAMP_DIR)/host_pango_unpacked: $(DL_DIR)/$(PANGO_SOURCE)
+ mkdir -p $(PANGO_HOST_DIR)
$(INFLATE$(suffix $(PANGO_SOURCE))) $< | \
- $(TAR) $(TAR_STRIP_COMPONENTS)=1 -C $(@D) $(TAR_OPTIONS) -
- toolchain/patch-kernel.sh $(@D) package/pango/ \*.patch
+ $(TAR) $(TAR_STRIP_COMPONENTS)=1 -C $(PANGO_HOST_DIR) $(TAR_OPTIONS) -
+ toolchain/patch-kernel.sh $(PANGO_HOST_DIR) package/pango/ \*.patch
touch $@
-$(PANGO_HOST_DIR)/.configured: $(PANGO_HOST_DIR)/.unpacked $(PKG_CONFIG_HOST_BINARY) $(CAIRO_HOST_BINARY) $(LIBGLIB2_HOST_BINARY)
- (cd $(@D); rm -rf config.cache; \
+$(STAMP_DIR)/host_pango_configured: $(STAMP_DIR)/host_pango_unpacked $(STAMP_DIR)/host_cairo_installed $(STAMP_DIR)/host_libglib2_installed
+ (cd $(PANGO_HOST_DIR); rm -rf config.cache; \
$(HOST_CONFIGURE_OPTS) \
CFLAGS="$(HOST_CFLAGS)" \
LDFLAGS="$(HOST_LDFLAGS)" \
- $(@D)/configure \
- --prefix=$(HOST_DIR)/usr \
- --sysconfdir=$(HOST_DIR)/etc \
+ ./configure \
+ --prefix="$(HOST_DIR)/usr" \
+ --sysconfdir="$(HOST_DIR)/etc" \
--disable-static \
$(if $(BR2_PACKAGE_XSERVER_none),--without-x,--with-x) \
--disable-debug \
)
touch $@
-$(PANGO_HOST_DIR)/.compiled: $(PANGO_HOST_DIR)/.configured
- $(HOST_MAKE_ENV) $(MAKE) -C $(@D)
+$(STAMP_DIR)/host_pango_compiled: $(STAMP_DIR)/host_pango_configured
+ $(HOST_MAKE_ENV) $(MAKE) -C $(PANGO_HOST_DIR)
touch $@
-$(PANGO_HOST_BINARY): $(PANGO_HOST_DIR)/.compiled
- $(HOST_MAKE_ENV) $(MAKE) -C $(<D) install
+$(STAMP_DIR)/host_pango_installed: $(STAMP_DIR)/host_pango_compiled
+ $(HOST_MAKE_ENV) $(MAKE) -C $(PANGO_HOST_DIR) install
+ touch $@
-host-pango: $(PANGO_HOST_BINARY)
+host-pango: $(STAMP_DIR)/host_pango_installed
host-pango-source: pango-source
host-pango-clean:
- rm -f $(addprefix $(PANGO_HOST_DIR)/,.unpacked .configured .compiled)
+ rm -f $(addprefix $(STAMP_DIR)/host_pango_,unpacked configured compiled installed)
-$(MAKE) -C $(PANGO_HOST_DIR) uninstall
-$(MAKE) -C $(PANGO_HOST_DIR) clean