summaryrefslogtreecommitdiffstats
path: root/package/netsnmp
diff options
context:
space:
mode:
authorLuca Ceresoli <luca@lucaceresoli.net>2012-03-15 22:04:27 +0100
committerPeter Korsgaard <jacmet@sunsite.dk>2012-03-18 21:41:23 +0100
commita0b75003521e695e5ac852e8aba19ca90e30ed1c (patch)
tree601e82a454f9cf3274e514a75c62f18d0a5eadfe /package/netsnmp
parent277bd1ff42504f91fe15de163aa62152784665ac (diff)
downloadbuildroot-novena-a0b75003521e695e5ac852e8aba19ca90e30ed1c.tar.gz
buildroot-novena-a0b75003521e695e5ac852e8aba19ca90e30ed1c.zip
netsnmp: add option to enable debugging code
Signed-off-by: Luca Ceresoli <luca@lucaceresoli.net> Acked-by: Arnout Vandecappelle (Essensium/Mind) <arnout@mind.be> Signed-off-by: Peter Korsgaard <jacmet@sunsite.dk>
Diffstat (limited to 'package/netsnmp')
-rw-r--r--package/netsnmp/Config.in9
-rw-r--r--package/netsnmp/netsnmp.mk6
2 files changed, 14 insertions, 1 deletions
diff --git a/package/netsnmp/Config.in b/package/netsnmp/Config.in
index 431be2d38..108ab8393 100644
--- a/package/netsnmp/Config.in
+++ b/package/netsnmp/Config.in
@@ -14,3 +14,12 @@ config BR2_PACKAGE_NETSNMP_ENABLE_MIBS
The net-snmp package contains a selection of MIB files.
Say yes if you want those MIB files installed on the target
and enable the code that parses the MIB files.
+
+config BR2_PACKAGE_NETSNMP_ENABLE_DEBUGGING
+ bool "Enable debugging code"
+ depends on BR2_PACKAGE_NETSNMP
+ help
+ By default net-snmp is compiled without debugging support
+ (--disable-debugging). Enable this options if you need debugging
+ support, including the ability to log with DEBUGMSG(),
+ DEBUGMSGTL() and companion macros.
diff --git a/package/netsnmp/netsnmp.mk b/package/netsnmp/netsnmp.mk
index 959e39f15..448e3fdb0 100644
--- a/package/netsnmp/netsnmp.mk
+++ b/package/netsnmp/netsnmp.mk
@@ -12,7 +12,7 @@ NETSNMP_CONF_ENV = ac_cv_NETSNMP_CAN_USE_SYSCTL=yes
NETSNMP_CONF_OPT = --with-persistent-directory=/var/lib/snmp --disable-static \
--with-defaults --enable-mini-agent --without-rpm \
--with-logfile=none --without-kmem-usage $(DISABLE_IPV6) \
- --enable-as-needed --disable-debugging --without-perl-modules \
+ --enable-as-needed --without-perl-modules \
--disable-embedded-perl --disable-perl-cc-checks \
--disable-scripts --with-default-snmp-version="1" \
--enable-silent-libtool --enable-mfd-rewrites \
@@ -55,6 +55,10 @@ define NETSNMP_REMOVE_MIBS_IPV6
endef
endif
+ifneq ($(BR2_PACKAGE_NETSNMP_ENABLE_DEBUGGING),y)
+ NETSNMP_CONF_OPT += --disable-debugging
+endif
+
define NETSNMP_INSTALL_TARGET_CMDS
$(TARGET_MAKE_ENV) $(MAKE) -C $(@D) \
DESTDIR=$(TARGET_DIR) install