summaryrefslogtreecommitdiffstats
path: root/package/netsnmp/netsnmp.mk
diff options
context:
space:
mode:
Diffstat (limited to 'package/netsnmp/netsnmp.mk')
-rw-r--r--package/netsnmp/netsnmp.mk6
1 files changed, 5 insertions, 1 deletions
diff --git a/package/netsnmp/netsnmp.mk b/package/netsnmp/netsnmp.mk
index 959e39f15..448e3fdb0 100644
--- a/package/netsnmp/netsnmp.mk
+++ b/package/netsnmp/netsnmp.mk
@@ -12,7 +12,7 @@ NETSNMP_CONF_ENV = ac_cv_NETSNMP_CAN_USE_SYSCTL=yes
NETSNMP_CONF_OPT = --with-persistent-directory=/var/lib/snmp --disable-static \
--with-defaults --enable-mini-agent --without-rpm \
--with-logfile=none --without-kmem-usage $(DISABLE_IPV6) \
- --enable-as-needed --disable-debugging --without-perl-modules \
+ --enable-as-needed --without-perl-modules \
--disable-embedded-perl --disable-perl-cc-checks \
--disable-scripts --with-default-snmp-version="1" \
--enable-silent-libtool --enable-mfd-rewrites \
@@ -55,6 +55,10 @@ define NETSNMP_REMOVE_MIBS_IPV6
endef
endif
+ifneq ($(BR2_PACKAGE_NETSNMP_ENABLE_DEBUGGING),y)
+ NETSNMP_CONF_OPT += --disable-debugging
+endif
+
define NETSNMP_INSTALL_TARGET_CMDS
$(TARGET_MAKE_ENV) $(MAKE) -C $(@D) \
DESTDIR=$(TARGET_DIR) install