summaryrefslogtreecommitdiffstats
path: root/package/mtd
diff options
context:
space:
mode:
authorDanomi Mocelopolis <d_mo1234@yahoo.com>2011-11-02 12:00:52 +0100
committerPeter Korsgaard <jacmet@sunsite.dk>2011-11-02 12:00:52 +0100
commit6473f6c035863ee846f3b1ebc239cabdcb497301 (patch)
tree0c6dc595e02f50163379759187e0902c1b0b81ad /package/mtd
parent3fb6010dca4447576fa36f4b5f845af986d39364 (diff)
downloadbuildroot-novena-6473f6c035863ee846f3b1ebc239cabdcb497301.tar.gz
buildroot-novena-6473f6c035863ee846f3b1ebc239cabdcb497301.zip
mtd: make sure that dest dir exists before installing mtd files
Closes #4387 Signed-off-by: Danomi Mocelopolis <d_mo1234@yahoo.com> Signed-off-by: Peter Korsgaard <jacmet@sunsite.dk>
Diffstat (limited to 'package/mtd')
-rw-r--r--package/mtd/mtd.mk4
1 files changed, 2 insertions, 2 deletions
diff --git a/package/mtd/mtd.mk b/package/mtd/mtd.mk
index ef876e2d3..1b23e8357 100644
--- a/package/mtd/mtd.mk
+++ b/package/mtd/mtd.mk
@@ -91,10 +91,10 @@ endef
define MTD_INSTALL_TARGET_CMDS
for f in $(MTD_TARGETS_y) ; do \
- install -m 0755 $(@D)/$$f $(TARGET_DIR)/usr/sbin/$$f ; \
+ install -D -m 0755 $(@D)/$$f $(TARGET_DIR)/usr/sbin/$$f ; \
done ; \
for f in $(MTD_TARGETS_UBI_y) ; do \
- install -m 0755 $(@D)/ubi-utils/$$f $(TARGET_DIR)/usr/sbin/$$f ; \
+ install -D -m 0755 $(@D)/ubi-utils/$$f $(TARGET_DIR)/usr/sbin/$$f ; \
done
endef