summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--CHANGES3
-rw-r--r--package/mtd/mtd.mk4
2 files changed, 4 insertions, 3 deletions
diff --git a/CHANGES b/CHANGES
index 74ec64fac..0043126bf 100644
--- a/CHANGES
+++ b/CHANGES
@@ -33,7 +33,7 @@
libglib2, libiconv, libmpd, libreplaygain, libroxml,
libsamplerate, libsndfile, libsoup, libsvgtiny, libtool,
lighttpd, links, linux-fusion, lite, lrzsz, lsof, lzo, lzop,
- makedevs, mcookie, mpg123, mpd, mpfr, musepack, mutt,
+ makedevs, mcookie, mpg123, mpd, mpfr, mtd, musepack, mutt,
mysql_client, ncftp, ncurses, neon, netcat, netsnmp, ntfs-3g,
ntfsprogs, ntp, openntpd, openssh, openssl, orc, pciutils,
psmisc, python, qt, quagga, radvd, rpm, rsync, samba, sawman,
@@ -70,6 +70,7 @@
#4183: Codesourcery toolchain download site has changed
#4231: libneon.so: undefined reference to `SSL_SESSION_cmp'
#4381: Add option to lighttpd to enable Lua support
+ #4387: Make sure that dest dir exists before installing mtd files
2011.08, Released August 31th, 2011:
diff --git a/package/mtd/mtd.mk b/package/mtd/mtd.mk
index ef876e2d3..1b23e8357 100644
--- a/package/mtd/mtd.mk
+++ b/package/mtd/mtd.mk
@@ -91,10 +91,10 @@ endef
define MTD_INSTALL_TARGET_CMDS
for f in $(MTD_TARGETS_y) ; do \
- install -m 0755 $(@D)/$$f $(TARGET_DIR)/usr/sbin/$$f ; \
+ install -D -m 0755 $(@D)/$$f $(TARGET_DIR)/usr/sbin/$$f ; \
done ; \
for f in $(MTD_TARGETS_UBI_y) ; do \
- install -m 0755 $(@D)/ubi-utils/$$f $(TARGET_DIR)/usr/sbin/$$f ; \
+ install -D -m 0755 $(@D)/ubi-utils/$$f $(TARGET_DIR)/usr/sbin/$$f ; \
done
endef