summaryrefslogtreecommitdiffstats
path: root/package/libpcap
diff options
context:
space:
mode:
authorPeter Korsgaard <jacmet@sunsite.dk>2012-09-05 16:04:52 +0200
committerPeter Korsgaard <jacmet@sunsite.dk>2012-09-05 16:04:52 +0200
commitdd00c5fcd072b4a1e3862c5af29f8c580acadd38 (patch)
tree84d1cd8e0523c19f434c42ab64808fd5203502ad /package/libpcap
parentebb2e058b0c1bdb988fd8340efa46e4cf067d5ac (diff)
downloadbuildroot-novena-dd00c5fcd072b4a1e3862c5af29f8c580acadd38.tar.gz
buildroot-novena-dd00c5fcd072b4a1e3862c5af29f8c580acadd38.zip
libpcap: fix build on microblaze
On microblaze, libpcap needs to be built with -fPIC rather than -fpic as reported by mrueg on IRC. Signed-off-by: Peter Korsgaard <jacmet@sunsite.dk>
Diffstat (limited to 'package/libpcap')
-rw-r--r--package/libpcap/libpcap.mk5
1 files changed, 5 insertions, 0 deletions
diff --git a/package/libpcap/libpcap.mk b/package/libpcap/libpcap.mk
index 04766eacd..7a1d32f40 100644
--- a/package/libpcap/libpcap.mk
+++ b/package/libpcap/libpcap.mk
@@ -21,4 +21,9 @@ LIBPCAP_CONF_ENV = ac_cv_linux_vers=2 \
ac_cv_header_linux_wireless_h=yes # configure misdetects this
LIBPCAP_CONF_OPT = --disable-yydebug --with-pcap=linux
+# microblaze needs -fPIC instead of -fpic
+ifeq ($(BR2_microblaze),y)
+LIBPCAP_CONF_ENV += CFLAGS="$(TARGET_CFLAGS) -fPIC"
+endif
+
$(eval $(autotools-package))