summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--package/libpcap/libpcap.mk5
1 files changed, 5 insertions, 0 deletions
diff --git a/package/libpcap/libpcap.mk b/package/libpcap/libpcap.mk
index 04766eacd..7a1d32f40 100644
--- a/package/libpcap/libpcap.mk
+++ b/package/libpcap/libpcap.mk
@@ -21,4 +21,9 @@ LIBPCAP_CONF_ENV = ac_cv_linux_vers=2 \
ac_cv_header_linux_wireless_h=yes # configure misdetects this
LIBPCAP_CONF_OPT = --disable-yydebug --with-pcap=linux
+# microblaze needs -fPIC instead of -fpic
+ifeq ($(BR2_microblaze),y)
+LIBPCAP_CONF_ENV += CFLAGS="$(TARGET_CFLAGS) -fPIC"
+endif
+
$(eval $(autotools-package))