summaryrefslogtreecommitdiffstats
path: root/package/libhid/libhid.mk
diff options
context:
space:
mode:
authorPeter Korsgaard <jacmet@sunsite.dk>2011-01-31 20:23:42 +0100
committerPeter Korsgaard <jacmet@sunsite.dk>2011-01-31 20:23:42 +0100
commit343eb8b58389ef2335e79238a088c543f1c602ca (patch)
treee83c379bcf420a8b57e074837992d0bb34ca32c8 /package/libhid/libhid.mk
parent7e7a8dc85e92171e93e14eb0323bc518ecada3cc (diff)
downloadbuildroot-novena-343eb8b58389ef2335e79238a088c543f1c602ca.tar.gz
buildroot-novena-343eb8b58389ef2335e79238a088c543f1c602ca.zip
package: add libhid
Based on patch by Johan Sagaert, but with some additional tweaks. Signed-off-by: Peter Korsgaard <jacmet@sunsite.dk>
Diffstat (limited to 'package/libhid/libhid.mk')
-rw-r--r--package/libhid/libhid.mk17
1 files changed, 17 insertions, 0 deletions
diff --git a/package/libhid/libhid.mk b/package/libhid/libhid.mk
new file mode 100644
index 000000000..ec6e5bb62
--- /dev/null
+++ b/package/libhid/libhid.mk
@@ -0,0 +1,17 @@
+#############################################################
+#
+# libhid
+#
+#############################################################
+
+LIBHID_VERSION = 0.2.16
+LIBHID_SOURCE = libhid-$(LIBHID_VERSION).tar.gz
+LIBHID_SITE = http://alioth.debian.org/frs/download.php/1958
+LIBHID_DEPENDENCIES = libusb-compat libusb
+LIBHID_INSTALL_STAGING = YES
+# configure runs libusb-config for cflags/ldflags. Ensure it picks up
+# the target version
+LIBHID_CONF_ENV = PATH=$(STAGING_DIR)/usr/bin:$(TARGET_PATH)
+LIBHID_CONF_OPT = --disable-swig --without-doxygen --disable-package-config
+
+$(eval $(call AUTOTARGETS,package,libhid))