summaryrefslogtreecommitdiffstats
path: root/package/libhid
diff options
context:
space:
mode:
authorPeter Korsgaard <jacmet@sunsite.dk>2011-01-31 20:23:42 +0100
committerPeter Korsgaard <jacmet@sunsite.dk>2011-01-31 20:23:42 +0100
commit343eb8b58389ef2335e79238a088c543f1c602ca (patch)
treee83c379bcf420a8b57e074837992d0bb34ca32c8 /package/libhid
parent7e7a8dc85e92171e93e14eb0323bc518ecada3cc (diff)
downloadbuildroot-novena-343eb8b58389ef2335e79238a088c543f1c602ca.tar.gz
buildroot-novena-343eb8b58389ef2335e79238a088c543f1c602ca.zip
package: add libhid
Based on patch by Johan Sagaert, but with some additional tweaks. Signed-off-by: Peter Korsgaard <jacmet@sunsite.dk>
Diffstat (limited to 'package/libhid')
-rw-r--r--package/libhid/Config.in8
-rw-r--r--package/libhid/libhid-0.2.16-fix-configure-typo.patch24
-rw-r--r--package/libhid/libhid.mk17
3 files changed, 49 insertions, 0 deletions
diff --git a/package/libhid/Config.in b/package/libhid/Config.in
new file mode 100644
index 000000000..73ff4b749
--- /dev/null
+++ b/package/libhid/Config.in
@@ -0,0 +1,8 @@
+config BR2_PACKAGE_LIBHID
+ bool "libhid"
+ select BR2_PACKAGE_LIBUSB
+ select BR2_PACKAGE_LIBUSB_COMPAT
+ help
+ Userspace library for accessing USB HID devices
+
+ http://libhid.alioth.debian.org
diff --git a/package/libhid/libhid-0.2.16-fix-configure-typo.patch b/package/libhid/libhid-0.2.16-fix-configure-typo.patch
new file mode 100644
index 000000000..870ecf24a
--- /dev/null
+++ b/package/libhid/libhid-0.2.16-fix-configure-typo.patch
@@ -0,0 +1,24 @@
+[PATCH] fix typo in configure
+
+Somehow a newline character has gotten inserted in the middle of the
+LDFLAGS assignment, breaking the build.
+
+Signed-off-by: Peter Korsgaard <jacmet@sunsite.dk>
+---
+ configure | 3 +--
+ 1 file changed, 1 insertion(+), 2 deletions(-)
+
+Index: libhid-0.2.16/configure
+===================================================================
+--- libhid-0.2.16.orig/configure
++++ libhid-0.2.16/configure
+@@ -23050,8 +23050,7 @@ echo "$as_me: doxygen disabled by config
+ CPPFLAGS=$(echo $CPPFLAGS)
+ CFLAGS=$(echo $OS_CFLAGS $LIBUSB_CFLAGS $CFLAGS)
+ CXXFLAGS=$(echo $CXXFLAGS)
+- LDFLAGS=$(echo $OS_LDFLAGS $LIBUSB_LIBS
+- $LDFLAGS)
++ LDFLAGS=$(echo $OS_LDFLAGS $LIBUSB_LIBS $LDFLAGS)
+
+
+
diff --git a/package/libhid/libhid.mk b/package/libhid/libhid.mk
new file mode 100644
index 000000000..ec6e5bb62
--- /dev/null
+++ b/package/libhid/libhid.mk
@@ -0,0 +1,17 @@
+#############################################################
+#
+# libhid
+#
+#############################################################
+
+LIBHID_VERSION = 0.2.16
+LIBHID_SOURCE = libhid-$(LIBHID_VERSION).tar.gz
+LIBHID_SITE = http://alioth.debian.org/frs/download.php/1958
+LIBHID_DEPENDENCIES = libusb-compat libusb
+LIBHID_INSTALL_STAGING = YES
+# configure runs libusb-config for cflags/ldflags. Ensure it picks up
+# the target version
+LIBHID_CONF_ENV = PATH=$(STAGING_DIR)/usr/bin:$(TARGET_PATH)
+LIBHID_CONF_OPT = --disable-swig --without-doxygen --disable-package-config
+
+$(eval $(call AUTOTARGETS,package,libhid))