summaryrefslogtreecommitdiffstats
path: root/package/json-c
diff options
context:
space:
mode:
authorAndreas Wetzel <andreas.wetzel@nanotronic.ch>2013-02-19 02:07:33 +0000
committerPeter Korsgaard <jacmet@sunsite.dk>2013-02-25 21:48:36 +0100
commitb7988b0fda1ceaacd7b23b2b98065a537c3cd87c (patch)
tree385fb9b4438231492c8c744fe3087adf262e647e /package/json-c
parent06b3e4c50d8c110f8b905f133afa31739d7817fd (diff)
downloadbuildroot-novena-b7988b0fda1ceaacd7b23b2b98065a537c3cd87c.tar.gz
buildroot-novena-b7988b0fda1ceaacd7b23b2b98065a537c3cd87c.zip
bump json-c to 0.10
this patch bumps json-c to version 0.10 and adapts the no-reentrant patch to the new version. Signed-off-by: Andreas Wetzel <andreas.wetzel@nanotronic.ch> Signed-off-by: Peter Korsgaard <jacmet@sunsite.dk>
Diffstat (limited to 'package/json-c')
-rw-r--r--package/json-c/json-c-no-reentrant.patch16
-rw-r--r--package/json-c/json-c.mk4
2 files changed, 9 insertions, 11 deletions
diff --git a/package/json-c/json-c-no-reentrant.patch b/package/json-c/json-c-no-reentrant.patch
index a01181cfb..31343c0a8 100644
--- a/package/json-c/json-c-no-reentrant.patch
+++ b/package/json-c/json-c-no-reentrant.patch
@@ -8,26 +8,24 @@ patch to avoid having to autoreconfigure the package.
Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
-Index: b/Makefile.am
+Index: b/Makefile.am.inc
===================================================================
---- a/Makefile.am
-+++ b/Makefile.am
-@@ -1,4 +1,4 @@
+--- a/Makefile.am.inc
++++ b/Makefile.am.inc
+@@ -1,2 +1,2 @@
-AM_CFLAGS = -Wall -Wwrite-strings -Werror -std=gnu99 -D_GNU_SOURCE -D_REENTRANT
+AM_CFLAGS = -Wall -Wwrite-strings -Werror -std=gnu99 -D_GNU_SOURCE
- EXTRA_DIST = README.html README-WIN32.html config.h.win32 doc
-
Index: b/Makefile.in
===================================================================
--- a/Makefile.in
+++ b/Makefile.in
-@@ -219,7 +219,7 @@
+@@ -263,7 +263,7 @@
top_build_prefix = @top_build_prefix@
top_builddir = @top_builddir@
top_srcdir = @top_srcdir@
-AM_CFLAGS = -Wall -Wwrite-strings -Werror -std=gnu99 -D_GNU_SOURCE -D_REENTRANT
+AM_CFLAGS = -Wall -Wwrite-strings -Werror -std=gnu99 -D_GNU_SOURCE
- EXTRA_DIST = README.html README-WIN32.html config.h.win32 doc
+ EXTRA_DIST = README.html README-WIN32.html config.h.win32 doc json-c.vcproj
+ SUBDIRS = . tests
lib_LTLIBRARIES = libjson.la
- pkgconfigdir = $(libdir)/pkgconfig
diff --git a/package/json-c/json-c.mk b/package/json-c/json-c.mk
index ed4a6d0a7..a0b5cae5a 100644
--- a/package/json-c/json-c.mk
+++ b/package/json-c/json-c.mk
@@ -4,8 +4,8 @@
#
################################################################################
-JSON_C_VERSION = 0.9
-JSON_C_SITE = http://oss.metaparadigm.com/json-c/
+JSON_C_VERSION = 0.10
+JSON_C_SITE = https://github.com/downloads/json-c/json-c
JSON_C_INSTALL_STAGING = YES
$(eval $(autotools-package))