summaryrefslogtreecommitdiffstats
path: root/package/json-c/json-c-no-reentrant.patch
diff options
context:
space:
mode:
Diffstat (limited to 'package/json-c/json-c-no-reentrant.patch')
-rw-r--r--package/json-c/json-c-no-reentrant.patch16
1 files changed, 7 insertions, 9 deletions
diff --git a/package/json-c/json-c-no-reentrant.patch b/package/json-c/json-c-no-reentrant.patch
index a01181cfb..31343c0a8 100644
--- a/package/json-c/json-c-no-reentrant.patch
+++ b/package/json-c/json-c-no-reentrant.patch
@@ -8,26 +8,24 @@ patch to avoid having to autoreconfigure the package.
Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
-Index: b/Makefile.am
+Index: b/Makefile.am.inc
===================================================================
---- a/Makefile.am
-+++ b/Makefile.am
-@@ -1,4 +1,4 @@
+--- a/Makefile.am.inc
++++ b/Makefile.am.inc
+@@ -1,2 +1,2 @@
-AM_CFLAGS = -Wall -Wwrite-strings -Werror -std=gnu99 -D_GNU_SOURCE -D_REENTRANT
+AM_CFLAGS = -Wall -Wwrite-strings -Werror -std=gnu99 -D_GNU_SOURCE
- EXTRA_DIST = README.html README-WIN32.html config.h.win32 doc
-
Index: b/Makefile.in
===================================================================
--- a/Makefile.in
+++ b/Makefile.in
-@@ -219,7 +219,7 @@
+@@ -263,7 +263,7 @@
top_build_prefix = @top_build_prefix@
top_builddir = @top_builddir@
top_srcdir = @top_srcdir@
-AM_CFLAGS = -Wall -Wwrite-strings -Werror -std=gnu99 -D_GNU_SOURCE -D_REENTRANT
+AM_CFLAGS = -Wall -Wwrite-strings -Werror -std=gnu99 -D_GNU_SOURCE
- EXTRA_DIST = README.html README-WIN32.html config.h.win32 doc
+ EXTRA_DIST = README.html README-WIN32.html config.h.win32 doc json-c.vcproj
+ SUBDIRS = . tests
lib_LTLIBRARIES = libjson.la
- pkgconfigdir = $(libdir)/pkgconfig