summaryrefslogtreecommitdiffstats
path: root/package/iproute2
diff options
context:
space:
mode:
authorPeter Korsgaard <jacmet@sunsite.dk>2011-07-21 23:10:33 +0200
committerPeter Korsgaard <jacmet@sunsite.dk>2011-07-21 23:10:33 +0200
commit9bd1fab4ea7721b40d9b72db6a46688a83e292fa (patch)
tree2ca4fa7286fc3af48d425df4e31259e12bcee450 /package/iproute2
parent4e7283604f584c79b928a4d90a98a8037c36f08e (diff)
downloadbuildroot-novena-9bd1fab4ea7721b40d9b72db6a46688a83e292fa.tar.gz
buildroot-novena-9bd1fab4ea7721b40d9b72db6a46688a83e292fa.zip
iproute2: ensure TARGET_CFLAGS are used
Signed-off-by: Peter Korsgaard <jacmet@sunsite.dk>
Diffstat (limited to 'package/iproute2')
-rw-r--r--package/iproute2/iproute2.mk3
1 files changed, 1 insertions, 2 deletions
diff --git a/package/iproute2/iproute2.mk b/package/iproute2/iproute2.mk
index fd78b3c45..bafb8c06f 100644
--- a/package/iproute2/iproute2.mk
+++ b/package/iproute2/iproute2.mk
@@ -29,13 +29,12 @@ define IPROUTE2_CONFIGURE_CMDS
rm -r $(IPROUTE2_DIR)/include/netinet
# arpd needs berkeleydb
$(SED) "/^TARGETS=/s: arpd : :" $(IPROUTE2_DIR)/misc/Makefile
- $(SED) "s:-O2:$(TARGET_CFLAGS):" $(IPROUTE2_DIR)/Makefile
echo "IPT_LIB_DIR:=/usr/lib/xtables" >>$(IPROUTE2_DIR)/Config
$(IPROUTE2_WITH_IPTABLES)
endef
define IPROUTE2_BUILD_CMDS
- $(MAKE) CC="$(TARGET_CC)" -C $(@D)
+ $(MAKE) CC="$(TARGET_CC)" CCOPTS="$(TARGET_CFLAGS) -D_GNU_SOURCE" -C $(@D)
endef
define IPROUTE2_INSTALL_TARGET_CMDS