summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--package/iproute2/iproute2.mk3
1 files changed, 1 insertions, 2 deletions
diff --git a/package/iproute2/iproute2.mk b/package/iproute2/iproute2.mk
index fd78b3c45..bafb8c06f 100644
--- a/package/iproute2/iproute2.mk
+++ b/package/iproute2/iproute2.mk
@@ -29,13 +29,12 @@ define IPROUTE2_CONFIGURE_CMDS
rm -r $(IPROUTE2_DIR)/include/netinet
# arpd needs berkeleydb
$(SED) "/^TARGETS=/s: arpd : :" $(IPROUTE2_DIR)/misc/Makefile
- $(SED) "s:-O2:$(TARGET_CFLAGS):" $(IPROUTE2_DIR)/Makefile
echo "IPT_LIB_DIR:=/usr/lib/xtables" >>$(IPROUTE2_DIR)/Config
$(IPROUTE2_WITH_IPTABLES)
endef
define IPROUTE2_BUILD_CMDS
- $(MAKE) CC="$(TARGET_CC)" -C $(@D)
+ $(MAKE) CC="$(TARGET_CC)" CCOPTS="$(TARGET_CFLAGS) -D_GNU_SOURCE" -C $(@D)
endef
define IPROUTE2_INSTALL_TARGET_CMDS