summaryrefslogtreecommitdiffstats
path: root/package/grep
diff options
context:
space:
mode:
authorPeter Korsgaard <jacmet@sunsite.dk>2008-07-23 10:35:53 +0000
committerPeter Korsgaard <jacmet@sunsite.dk>2008-07-23 10:35:53 +0000
commit9a1526d7d9474a5b3a43f0c0e453f431428fafcc (patch)
treef9ec4f754f0525f1c71cb6b4450d6e7e5f68e85d /package/grep
parenta649ed0da05c572d1082f91e3abe3ab6fe3a6c09 (diff)
downloadbuildroot-novena-9a1526d7d9474a5b3a43f0c0e453f431428fafcc.tar.gz
buildroot-novena-9a1526d7d9474a5b3a43f0c0e453f431428fafcc.zip
grep: gettext/libintl is only required if locale is enabled
Diffstat (limited to 'package/grep')
-rw-r--r--package/grep/Config.in6
-rw-r--r--package/grep/grep.mk6
2 files changed, 8 insertions, 4 deletions
diff --git a/package/grep/Config.in b/package/grep/Config.in
index 3d488e326..3795330ce 100644
--- a/package/grep/Config.in
+++ b/package/grep/Config.in
@@ -1,8 +1,8 @@
config BR2_PACKAGE_GREP
bool "grep"
- select BR2_PACKAGE_GETTEXT
- select BR2_PACKAGE_LIBINTL
+ select BR2_PACKAGE_GETTEXT if BR2_ENABLE_LOCALE
+ select BR2_PACKAGE_LIBINTL if BR2_ENABLE_LOCALE
help
The GNU regular expression matcher.
- Needs gettext
+
http://www.gnu.org/software/grep/grep.html
diff --git a/package/grep/grep.mk b/package/grep/grep.mk
index c12b1df1c..0e99698e0 100644
--- a/package/grep/grep.mk
+++ b/package/grep/grep.mk
@@ -11,6 +11,10 @@ GNUGREP_CAT:=$(ZCAT)
GNUGREP_BINARY:=src/grep
GNUGREP_TARGET_BINARY:=bin/grep
+ifeq ($(BR2_ENABLE_LOCALE),y)
+GNUGREP_EXTRA_DEPS:=gettext libintl
+endif
+
$(DL_DIR)/$(GNUGREP_SOURCE):
$(WGET) -P $(DL_DIR) $(GNUGREP_SITE)/$(GNUGREP_SOURCE)
@@ -65,7 +69,7 @@ grep-target_binary: $(GNUGREP_DIR)/$(GNUGREP_BINARY)
cp -a $(GNUGREP_DIR)/src/grep $(GNUGREP_DIR)/src/egrep \
$(GNUGREP_DIR)/src/fgrep $(TARGET_DIR)/bin/; fi
-grep: uclibc gettext libintl grep-target_binary
+grep: uclibc $(GNUGREP_EXTRA_DEPS) grep-target_binary
grep-clean:
$(MAKE) DESTDIR=$(TARGET_DIR) -C $(GNUGREP_DIR) uninstall