summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--package/grep/Config.in6
-rw-r--r--package/grep/grep.mk6
2 files changed, 8 insertions, 4 deletions
diff --git a/package/grep/Config.in b/package/grep/Config.in
index 3d488e326..3795330ce 100644
--- a/package/grep/Config.in
+++ b/package/grep/Config.in
@@ -1,8 +1,8 @@
config BR2_PACKAGE_GREP
bool "grep"
- select BR2_PACKAGE_GETTEXT
- select BR2_PACKAGE_LIBINTL
+ select BR2_PACKAGE_GETTEXT if BR2_ENABLE_LOCALE
+ select BR2_PACKAGE_LIBINTL if BR2_ENABLE_LOCALE
help
The GNU regular expression matcher.
- Needs gettext
+
http://www.gnu.org/software/grep/grep.html
diff --git a/package/grep/grep.mk b/package/grep/grep.mk
index c12b1df1c..0e99698e0 100644
--- a/package/grep/grep.mk
+++ b/package/grep/grep.mk
@@ -11,6 +11,10 @@ GNUGREP_CAT:=$(ZCAT)
GNUGREP_BINARY:=src/grep
GNUGREP_TARGET_BINARY:=bin/grep
+ifeq ($(BR2_ENABLE_LOCALE),y)
+GNUGREP_EXTRA_DEPS:=gettext libintl
+endif
+
$(DL_DIR)/$(GNUGREP_SOURCE):
$(WGET) -P $(DL_DIR) $(GNUGREP_SITE)/$(GNUGREP_SOURCE)
@@ -65,7 +69,7 @@ grep-target_binary: $(GNUGREP_DIR)/$(GNUGREP_BINARY)
cp -a $(GNUGREP_DIR)/src/grep $(GNUGREP_DIR)/src/egrep \
$(GNUGREP_DIR)/src/fgrep $(TARGET_DIR)/bin/; fi
-grep: uclibc gettext libintl grep-target_binary
+grep: uclibc $(GNUGREP_EXTRA_DEPS) grep-target_binary
grep-clean:
$(MAKE) DESTDIR=$(TARGET_DIR) -C $(GNUGREP_DIR) uninstall